Error on moodle after upgrade

I updated my moodle from 2.4 to 3.0, and now I got this :
Parse error: syntax error, unexpected '[' in /var/www/moodle/lib/outputrenderers.php on line 110

How can I fix it ?
Jose BredariolPMPAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sarabandeCommented:
perhaps you should uninstall both versions, remove all references to 'moodle' from your system and then download and install the newest version.

of course that doesn't help from porting any existing projects and source file to the newer version but should help from errors like the one you reported.

Sara
nociSoftware EngineerCommented:
be carefull to keep original config files for reference, and keep file content that my be stored below the moodle root.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jose BredariolPMPAuthor Commented:
thanks all
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.