We help IT Professionals succeed at work.
Get Started

BitLocker Recovery Information not backing up to AD DS

3,468 Views
Last Modified: 2016-03-08
I am not able to get BitLocker recovery information to back up to Active Directory.  My understanding is that the BitLocker and TPM recovery information should show up in the BitLocker Recovery tab of the computer object in AD, but it isn't.  Here is what I've done:

- Set up a GPO with the following:
      Computer/Policies/Administrative Templates/System/Trusted Platform Module Services: Turn on TPM backup to Active Directory Domain Services - enabled
      Computer/Policies/Administrative Templates/Windows Components/BitLocker Drive Encryption: Store BitLocker recovery information in Active Directory Domain Services (Server 2008 and Vista)
      Computer/Policies/Administrative Templates/Windows Components/BitLocker Drive Encryption/Operating System Drives: Choose how BitLocker-protected system Drives can be recovered
            Allow Data recovery agent: Enabled
            Configure user storage of BitLocker recovery information:  Allow 48-digit recovery password, Allow 256-bit recovery key
            Omit recovery options from the BitLocker setup wizard: Disabled
            Save Bitlocker recovery information to AD DS for operating system drives: Enabled
            Configure Storage of BitLocker recovery information to AD DS: Store recovery passwords and key packages
            Do not enable BitLocker until recovery information is stored to AD DS for operating system drives: Disabled
      Computer/Policies/Administrative Templates/Windows Components/BitLocker Drive Encryption/Operating System Drives: Require Additional authentication at Startup: Enabled
            Allow Bitlocker without a compatible TPM: enabled
            Settings for computers with a TPM:
                  Configure TPM startup: allow TPM
                  Configure TPM startup pin: Allow startup PIN with TPM
                  COnfigure TPM startup key: allow startup key with TPM
                  Configure TPM startup key and PIN: Allow startup key and PIN with TPM

- Set AD permissions to give SELF Write msTPM-OwnerInformation and Write msTPM-TpmInformationForComputer per https://technet.microsoft.com/en-us/library/jj592683.aspx

We are running 2012 R2 DCs running  at 2012 R2 domain and forest functional levels, so my understanding is there aren't any required schema extensions.  The computer is running Windows 8.1 Pro.  I have verified that the computer is applying the GPO and I have double-checked that these permissions are applying to my test machine, but still no recovery information in AD.  I have decrypted and encrypted the machine multiple times.  What am I doing wrong?
Comment
Watch Question
CERTIFIED EXPERT
Distinguished Expert 2019
Commented:
This problem has been solved!
Unlock 1 Answer and 2 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE