Link to home
Start Free TrialLog in
Avatar of rm103
rm103Flag for United States of America

asked on

SSRS Report Builder - Export to CSV issue with extra Double Quotes

I created a report in SSRS to be used to generate a flat file for the printing of Product Labels in Bartender.  At the top of the report, I have a string of information that needs to be printed exactly as indicated below.  The line with a header of "Yours-" is what is currently displaying when you open the CSV with Note Pad and the line with a header of "Printer-" is what should be printing.  If I open the file in Excel, everything appears to be fine.  The only thing that changes is the Label Format field which is being updated from a SQL Table (it's the extension that ends in .btw).  

Yours-
"%BTW% /F=""\\Sav2008\Sage\Label\MAS_SWK\format\format2.btw"" /D=""<Trigger File Name>"" /p /C=1 /DD /DBTEXTHEADER=3 /R=3 "

Printer-
%BTW% /F="\\Sav2008\Sage\Label\MAS_SWK\format\WMS\WMS_format7.btw" /D="<Trigger File Name>" /p /C=1 /DD /DBTEXTHEADER=3 /R=3
%END%

I found an article online that told me to modify the following information in the rsreportserver.config file but it appears to not have solved the issue.  I need to have the code in there to remove the headers but am not sure about the rest or if I need any additional code to get the "" from showing up when there only should be one ".

      <Extension Name="CSV" Type="Microsoft.ReportingServices.Rendering.DataRenderer.CsvReport,Microsoft.ReportingServices.DataRendering">
      <OverrideNames>
         <Name Language="en-us"> CSV No Header</Name>
      </OverrideNames>
      <Configuration>
         <DeviceInfo>
            <NoHeader>true</NoHeader>
            <ExcelMode>true</ExcelMode>
            <Qualifier></Qualifier>
            <Encoding>ASCII</Encoding>
         </DeviceInfo>
      </Configuration>
      </Extension>
ASKER CERTIFIED SOLUTION
Avatar of Russell Fox
Russell Fox
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of rm103

ASKER

Thanks.