Link to home
Create AccountLog in
Avatar of iws_aw_2015

asked on

Server 2008 R2 opening sessions Very Slow

We have 2x 2008 R2 servers. First one has Remote Desktop Connections enabled on it, second one is for DC and SQL Server. A few days ago, we installed SpyHunter on RDS server, then run it once (everything appeared ok) and uninstalled it next on Friday evening. Administrator account was used for this purpose. Opening Local and RDP is still as fast as before for Administrator Session: about 5 seconds. But on Monday morning there was a change with Authenticating: we needed to create new credentials for RDP users to open RDP sessions. All user accounts became Very Slow while Opening Local or RDP session on our 2008 R2 server: about more than 2 minutes to get to the Desktop, instead of 5 seconds as usually. Only Administrator account opens normally (Local and RDP). Fortunately, everything works fine for all other users when they access Desktop. We noticed a question about DNS change that we accepted, while SpyHunter was scanning server. Think this a the trouble. We asked Enigma Software for any issue about SpyHunter, but so far, they didn’t answer us.

Any ideas ?
Avatar of Chris H
Chris H
Flag of United States of America image

Link to home
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of iws_aw_2015


Thanks a lot choward16980.
I just followed your comments... unfortunately, it still doesn't work but your help is quite fine.
Trouble might be about DNS entries... I found 10 ones, instead of 2 previous values !
Again, thanks a lot for your help, choward16980.
I restored previous DNS entries, but so far, trouble remained exactly the same.

Finally, I decided to add 2 policies using GPEDIT.msc to setup max network waiting time while opening session.
Now, opening a Local or DRD session for all users needs about 10 seconds.
That remains twice longer than previously: it's not as fast as before Monday, but still much better than waiting about 2 minutes for users !