Windows Server 2012R2 Time Incorrect

Our domain controller is Windows 2012R2.  Since the time change this weekend I've reset the time on the server numerous times, but it will not maintain the correct time.  I do have the daylight savings time box checked, and it is set to the correct time zone (central US).  How do I fix this?
nplanekOffice ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brian BEE Topic Advisor, Independant Technology ProfessionalCommented:
Do you know if the server is synching to a time source?

Is it dropping back an hour? Make sure you have all the latest patches installed are there are a couple of patches required on the server to adjust them to the "new" dailylight savings.
MasterNe0Commented:
Check the bios to see if maybe the clock off on that side. if the bios clock is wrong, even by a few minutes. it can cause the OS to be off.

We use a third party free app to keep our server clock in sync with the world: http://www.worldtimeserver.com/atomic-clock/
Lee W, MVPTechnology and Business Process AdvisorCommented:
Also make sure you're not in the Indiana Central time zone - they don't observe DST.
Amazon Web Services

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

Senior IT System EngineerSenior Systems EngineerCommented:
Hi @NPlanek,

Have you synched this domian controller to a NTP source using any of the methods described in: http://blogs.technet.com/b/nepapfe/archive/2013/03/01/it-s-simple-time-configuration-in-active-directory.aspx

if yes, please try this simple steps below to reset the NTP service:

w32tm /config /syncfromflags:domhier /update
w32tm /resync /rediscover
net stop w32time
net start w32time

Open in new window



if the reset still not happening, then try this additonal lines to re-register the service:

net stop w32time
w32tm /unregister
w32tm /register
net start w32time

w32tm /config /syncfromflags:domhier /update
w32tm /resync /rediscover
net stop w32time
net start w32time

Open in new window

Thomas KetnerActive Directory Infrastructure/Security ArchitectCommented:
Is this a VM or is it a Physical box?

IF PHYSICAL

UDP Port 123 must be open between your server and NTP devices

ON PDCe
w32tm /config /manualpeerlist:"IPPrimary,0x9 IPSecondary,0x1" /syncfromflags:manual /reliable:yes /update
net stop w32time
net start w32time
w32tm /resync /nowait /rediscover

###wait about 30 seconds
w32tm /query /peers

You should get the peers you set

ON STANDARD DCs
w32tm.exe /config /syncfromflags:domhier /reliable:no /update
net stop w32time
net start w32time

w32tm /resync /nowait /rediscover

###wait about 30 seconds
w32tm /query /peers

You should see PDCe as the peer

IF VM

Follow this to make sure your guest is not syncing with the Host

http://www.mustbegeek.com/time-synchronization-between-virtual-machine-and-esxi-server/

POWERSHELL WAY

########################
# Disable VM Time Sync #
########################
Write-Verbose “If the Server is running in a VMWare VM, ensure VMWare sync is disabled. `r “
IF ($VMWareServiceCount -gt 0)
    {  ## OPEN IF The server is a VM running on a VMWare host
        Write-Output “$Computer is running on a VMWare VM. `r “
        Write-Output “Disabling VMWare VM time synchronization with host. `r “
        $TimeResult = ‘C:\Program Files\VMware\VMware Tools\VMwareService.exe -cmd “vmx.set_option synctime 1 0″‘
        Write-Output “VMWare VM time synchronization with host is Disabled. `r “
    }  ## OPEN IF The server is a VM running on a VMWare host

ON PDCe
w32tm /config /manualpeerlist:"IPPrimary,0x9 IPSecondary,0x1" /syncfromflags:manual /reliable:yes /update
net stop w32time
net start w32time
w32tm /resync /nowait /rediscover

###wait about 30 seconds
w32tm /query /peers

You should get the peers you set

ON STANDARD DCs
w32tm.exe /config /syncfromflags:domhier /reliable:no /update
net stop w32time
net start w32time

w32tm /resync /nowait /rediscover

###wait about 30 seconds
w32tm /query /peers

You should see PDCe as the peer
nplanekOffice ManagerAuthor Commented:
I worked with HP support and was told this is a known problem with some HP Window servers.  They are working on a permanent fix, but for now they provided the following workaround:

1) Create a new DWORD sized Microsoft Windows registry setting named RealTimeIsUniversal under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\ and set the value to '1'. This option will cause the Windows operating system to treat the Real Time Clock time as UTC rather than local time.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nplanekOffice ManagerAuthor Commented:
It was provided by HP, and it worked.
Senior IT System EngineerSenior Systems EngineerCommented:
Hi Nplanek,

Does the system is a HP physical machine ?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.