Windows 10 EMC

CTCRM
CTCRM used Ask the Experts™
on
I need to install EMC (Ex2010) onto my Windows 10 client and get the below message when launching EMC.

Connecting to remoter server ********.uk failed with the following error message: The Exchange Management COnsole can't connect to this server because the versions are incompatible, the current server versio is 14.2.247.5.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Most Valuable Expert 2014
Commented:
Not supported.

If you are 14.2 then that is Exchange 2010 SP2, which is also out of support.
Therefore I would suggest that you start by installing Exchange 2010 SP3, then the latest rollup on to your main server.

However with Windows 10, you will have to RDP to the Exchange server to run EMC.

Simon.
CTCRMInfrastructure Engineer

Author

Commented:
Thanks Simon

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial