How can I fix the ' xhci_drop_endpoint called with disabled ep' error in Ubuntu?

I have an Odroid XU4 with Ubuntu 15.10 installed (flashed from http://odroid.com/dokuwiki/doku.php?id=en:xu3_release_linux_ubuntu)

When I use the USB3 ports, I get drop outs and slow speed. The syslog shows a lot of :

Mar 24 17:00:00 odroid kernel: [   18.967657] [c6] xhci-hcd xhci-hcd.5.auto: xHCI xhci_drop_endpoint called with disabled ep ddd5fd80

Open in new window



Googling that error shows that others have seen the same issue with xhci, but I cannot see a fix, other than changing the setting XHCI mode in the BIOS from "Smart Auto" to "disabled." Ubuntu will then use EHCI, which works, but at USB2 speed, not USB3.

I have 2 questions:

1-To test that this is in fact the issue, i need to disable XHCI in the odroid bios. How do I do this? I only see the boot/boot.ini file, and there are no XHCI settings.

2- As I will need USB3 speed, how can I get rid of the xhci_drop_endpoint error and get my USB3 devices working at high speed?

Thank you.
chemicalx001Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
Do not have this on hand nor have I, but found the following on xu4 and issues reported. Tge suggested fix is.. Peculiarly

http://forum.odroid.com/viewtopic.php?f=95&t=15302

See if the remedy some claimed in their case worked, works for you in your case.
The issue could be a distraction requiring only the removal/reinsertion of the xu4 to make sure all the contacts are set....
nociSoftware EngineerCommented:
Well not that peculiar, apparently while soldering the boards the contacts can become dirty.
Normally a manufacturer will clean them after soldering, obviously they were not too successful with some batches.

should be a one time issue, otherwise there is more wrong and you need to check what goes wrong...
can be firmware issues, kernel drivers issues or plain old hardware faults. (So check if there is power on the port
by f.e. check if you can charge a phone through it).
chemicalx001Author Commented:
I have tried cleaning the contacts,  and updated the firmware and kernel to the latest version. I still see the xhci error.

To the first part of my question,  to double check that this is in fact the issue,  how can I change the xhci settings?
Get a highly available system for cyber protection

The Acronis SDI Appliance is a new plug-n-play solution with pre-configured Acronis Software-Defined Infrastructure software that gives service providers and enterprises ready access to a fault-tolerant system, which combines universal storage and high-performance virtualization.

nociSoftware EngineerCommented:
Ok some education...
These are ARM based systems, they have NO BIOS as you know it.
Mostly there is a bootloader named U-Boot involved.
The flash has softpartitions.. (there is no administration of partitions, it is a convention used & obeyd by all programs on a platform....  

XU4 platform used UBOOT (see: http://odroid.com/dokuwiki/doku.php?id=en:odroid-xu4) .
To load a program you effective issue some basic instructions like COPY A BLOB of data to some address, jump to address.

(See example i refered to.. setenv bootcmd="some instructions" I could not find instructions there for USB...)
Now this tells the same but has more detailed info on why USB3 can be affected and USB2 isn't
https://archlinuxarm.org/forum/viewtopic.php?f=60&t=9380 
From that there must be 5 tiny contacts that need to be cleaned not exp. longer USB2  strips in the connection.

Then there are possibly issues with the powering of the USB ports, according to this article: http://forum.odroid.com/viewtopic.php?f=117&t=18979 
It seems the powersupply for the USB3 ports is not exactly the right solution...

Did you check if the ports still ISSUE power?   (like you can charge a phone with it?)
Gerwin Jansen, EE MVETopic Advisor Commented:
How are you powering the device? I would recommend at least a 1A 5V power supply, better 2A.
gheistCommented:
Looks like Exynos probem if not kernel bug.
You can join mee--tooo party here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1371233

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
chemicalx001Author Commented:
I've requested that this question be deleted for the following reason:

it wont let me close it any other way
arnoldCommented:
What other way do you want to close it? Were any of the suggestions helpful; you want to choose one or multiple, or .....
chemicalx001Author Commented:
closed. Was a browser bug.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.