sharing a folder from a non-domain workstation

HI everyone-
i have a share on a workgroup computer that has

share permissions... everyone full control
ntfs permissions... everyone full control

It still prompts for passwords everytime you try to connect to it.

The os on the workstation is windows 7 pro
jamesmetcalf74Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

William FulksSystems Analyst & WebmasterCommented:
How do you login to that workgroup PC?

If you are prompted from a login while connection from another PC, try using machinename\username as the login and then whatever your password is to connect. If you don't have a password set, that may cause a problem.
jamesmetcalf74Author Commented:
when I browse to the share from my domain connected computer
run -> ipaddress\share  

it then prompts for username and password
I input    hostname\localusername
                pwd

and then I have access to it

I would like it to give access to its files to anyone without prompting for credentials
it_saigeDeveloperCommented:
Try enabling the Network access policy, 'Let Everyone permissions apply to anonymous users'.

1. Launch secpol.msc

Capture.JPGCapture.JPG

2. Open Local Policies; Security Options

Capture.JPG

3. Locate and enable the policy '[b]Network access: Let Everyone permissions apply to anonymous users[/b]'

Capture.JPG-saige-
Jackie Man IT ManagerCommented:
You need to make two changes (1) enable Public Sharing; and (2) turn off Password Protection Sharing.

Enable Public Sharing
http://windows.microsoft.com/en-us/windows7/share-files-using-the-public-folders

Turn off Password Protection Sharing
http://www.sevenforums.com/tutorialsU/185429-password-protected-sharing-turn-off-windows-7-a.html

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jamesmetcalf74Author Commented:
Im working!
Thanks gentlemen
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.