RemoteApp Published App won't accept credentials

We are running RemoteApp on a Windows 2008 R2 server.  We are publishing 3 apps, one of which is Excel.  We have 5 office worldwide.  One of our USA offices is having problems connecting to the Published Apps.  We are able to logon to RemoteApp with no problem.  When we launch any of the Published Applications, we are prompted for user credentials.  When we enter the credentials, we are receiving an error, "The logon attempt failed."  The clients are all running Windows 7 and IE11.  Something seems to have changed for this site, because we were able to launch Published Apps from this network previously.  Published Apps are working for all other locations.

remoteapp-error.PNG
Mike OrtherSystems EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Scott GorcesterCTOCommented:
Do you have local Domain controllers to authenticate users? Did passwords recently change and are all domain controllers fully syncronized?

Scott gorcester
Mike OrtherSystems EngineerAuthor Commented:
Thanks for your reply Scott:

I do have a local Domain Controller.  No passwords have changed.  Domain Controllers are fully synchronized.

Another interesting thing, I just tested two of my 2k3 member servers, and I am able to connect to the Remote App without any problem.  Both of these servers are are authenticating on the same domain controller as my Windows 7 machines.
Scott GorcesterCTOCommented:
Look at this......

While troubleshooting a problem with the SSO-feature lately, we got an error message saying “The logon attempt failed”.

The solution turned out to be rather simple. While the default logon page for RD Web Access indicates “Domain/user name” for the user name field, using only the user name works fine:


This works fine as long as your not using RD Gateway and SSO, then the error message mentioned will occur when trying to start a RemoteApp.
When RD Gateway and SSO are being used, you must supply the domain as part of the user name (domain user name), else the SSO-feature will break.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mike OrtherSystems EngineerAuthor Commented:
OMG that worked.  I am not sure why this works differently than all the other sites,  but at this point I do not care.  Thanks you so much Scott.  You really hit the nail on the head.  Regards, Mike
Mike OrtherSystems EngineerAuthor Commented:
This worked perfectly.  Thank you again Scott.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.