Link to home
Start Free TrialLog in
Avatar of scotgwhiz
scotgwhizFlag for United States of America

asked on

IT Manager

I am trying to install Oracle ODBC Instant Client. The downloads are 11.2.0.4, 64 bit basic and ODBC. I have unzipped the files to the same directory, basic first and put the directory in the PATH. I put the tns_admin .ora file and sql.ora file in the same directory and created the TNS_ADMIN variable. I then ran the ODBC install bat file and the driver installed to the Data Sources. When I try to add a System DSN using the driver I get an error: The setup routines for the Oracle in instantclient_11_2 ODBC driver could not be loaded due to system error code 14001: The application has failed to start because its sided-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail. (C:\Oracle\instantclient_11_2\SQORAS32.DLL).

Any suggestions?

Thanks
Avatar of slightwv (䄆 Netminder)
slightwv (䄆 Netminder)

>>Please see the application event log or use the command-line sxstrace.exe tool for more detail

Did you check the Windows Event log?

There should be more details in there.
SOLUTION
Avatar of Arana (G.P.)
Arana (G.P.)

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of scotgwhiz

ASKER

I have attached a new file with the event error log.

I have also installed the Security Update for Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package (KB2538242)

Installation date: ‎4/‎6/‎2016 10:46 AM

Installation status: Successful

No luck
Try using 32bit version of Data Sources you can find it here : C:\Windows\SysWOW64\odbcad32.exe
Attached are the error messages and the event error log..
Doc1.pdf
Doc2.pdf
>>Attached are the error messages and the event error log..

Sorry but those aren't legible.

You should be able to copy the event log to notepad and post inline here as code or quote or attach as a .txt file.
Well that's unfortunate....

Log Name:      Application
Source:        SideBySide
Date:          4/6/2016 10:17:24 AM
Event ID:      33
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      OC1.acns.ColoState.EDU
Description:
Activation context generation failed for "C:\Oracle\instantclient_11_2\SQORAS32.DLL". Dependent Assembly Microsoft.VC80.MFC,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.762" could not be found. Please use sxstrace.exe for detailed diagnosis.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="SideBySide" />
    <EventID Qualifiers="49409">33</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2016-04-06T16:17:24.000000000Z" />
    <EventRecordID>2065</EventRecordID>
    <Channel>Application</Channel>
    <Computer>OC1.acns.ColoState.EDU</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Microsoft.VC80.MFC,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.762"</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>C:\Oracle\instantclient_11_2\SQORAS32.DLL</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I installed the 64 bit version of the Microsoft Visual C++ 2005 Redistributable Package and tried it with no success but then ran windows updates and it updated the Redistributable Package with a security update and Voila!.... it works...Thanks to Slightwv and Arana for your assistance.
The security update does appear to be the "magic" assuming you saw the same thread I did...

Glad to help.
I marked yours as the Best Solution but it is not appearing to be highlighted. Do you see it as the Best Solution?
Thanks again!
I see flagged as Best.