Exchange 2013 - POP3 problem, I think

crp0499
crp0499 used Ask the Experts™
on
we bought this crappy ticketing tool named jira and for some god awful reason, it sends mail via POP3.  So, the service account we created for Jira has to have pop3 enabled.  

a previous admin tackled this problem a few weeks ago and today, I found out that he ran some sort of powershell and enabled pop3 for every mailbox in the domain.  While this isn't earth ending, it makes some people uncomfortable so I've been asked to turn it off for everyone EXCEPT this Jira account.

I need some help making that happen.

Thanks

Cliff
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Just get all the mailboxes where the name isn't the Jira mailbox, then pipe to Set-CASMailbox to disable POP.  Something like this:

Get-Mailbox -ResultSize Unlimited |
Where{$_.samaccountname -ne "YourJiraMailbox"} |
Set-CASMailbox -POPEnabled:$false

Open in new window


Use the -WhatIf parameter if you want to check what's effected first.  BTW you can filter on any identifying property doesn't have to be samAccountName.

Let me know how it goes.
crp0499CEO

Author

Commented:
Cool.  I'll give it a go in the AM.
Most Valuable Expert 2014

Commented:
POP3 is a receiving protocol, has nothing to do with sending.

Therefore if it needs to send email you will need to have a receive connector to allow for relaying if sending to external recipients.

POP3 would be used for inbound email only.

Simon.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial