Permissions Issue in Windows Server 2012

Ok, so I'm banging my head on a desk right now, because I know it should work but it doesn't.

I have a simple folder on Server 2012.   I've set the permissions to Full for Domain Admins and Owner Domain Admins.   I'm obviously a Domain Admin.     I also have a clients Security Group set to full permissions.     I've also added a share for both Domain Admins and Client SG.    I'm able to open an browse the folder while looking at it as a share, however locally I'm getting a You don't currently have permission to access this folder.  

Please help me, I'm starting to feel like a newbie.
LVL 2
C_ParlatoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ChrisSr. Systems EngineerCommented:
Did you not add NTFS permissions, and only added share permissions?
McKnifeCommented:
Ever heard of UAC? That is UAC live.
You can solve it in many ways:
-use a different file explorer and elevate it (for example total commander)
-tweak explorer so that you can elevate it
-turn off UAC (usually not recommendable)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
C_ParlatoAuthor Commented:
I disabled UAC I thought.   Does it not completely go away.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

ChrisSr. Systems EngineerCommented:
Can you paste some screenshots of your properties, share settings and security?
McKnifeCommented:
After a reboot, it does. On win10 however, using the lever does not do the same as using the registry. Maybe already the same on server 2012? That key: https://gallery.technet.microsoft.com/Registry-Key-to-Disable-UAC-45d0df25
C_ParlatoAuthor Commented:
Disabling the UAC through the registry worked.   I had though by dropping it in Control Panel - Users - UAC would be enough.   It wasn't.
McKnifeCommented:
Interesting. So the same issue is already present on 2012 and maybe also on win8.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.