Issues with MDT and the Surface Pro 3

I have an odd issue with the Surface Pro 3. I am using MDT/WDS to capture and deploy images to our machines. I have been able to capture an image using LiteTouch with no issue, and am able to install a fresh Win10 OS using MST. When I attempt to deploy my custom image, it hangs on the step “Format and Partition Disk (UEFI)”. Afterwards, I open CMD and check the disks under dispart, and the disk is missing.

If I reboot and go into WinPE then exit to command prompt, and attempt to format a partition manually, the disk will drop and not be available until I reboot. Has anyone seen this behavior?
LA_AdminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPRetiredCommented:
that means that you need the storage driver added to windows PE
LA_AdminAuthor Commented:
So I re-imported all of the drivers for the Surface Pro 3 from the MS site, and completely rebuilt the boot images using MDT (which fixed an unrelated driver issue I was having with a different model). I got the same issue, same error. I am manually going through the unpacked driver directories, and I do not see any storage drivers in SurfacePro3_Win10_160420_0.zip (https://www.microsoft.com/en-us/download/details.aspx?id=38826)

Did I miss it, or is it really not in there?
LA_AdminAuthor Commented:
Ok, I went to a built-from-scratch SP3, and looked for the storage driver. Found that it was named OEM57.inf. I copied and pasted that to MDT. I injected it to WinPE, and tried again. Failed. I then rebuilt the DeploymentShare boot images, and verified that the driver was injected. Tried again, failed. So either that is not the correct driver, or I am still doing something wrong.

Does anyone have any ideas?
Get a highly available system for cyber protection

The Acronis SDI Appliance is a new plug-n-play solution with pre-configured Acronis Software-Defined Infrastructure software that gives service providers and enterprises ready access to a fault-tolerant system, which combines universal storage and high-performance virtualization.

LA_AdminAuthor Commented:
Anyone have any ideas?
David Johnson, CD, MVPRetiredCommented:
Did you import all of the drivers and add a selection profile? Here is a good guide
http://www.microsoft.com/en-us/download/details.aspx?id=45292

After importing the drivers you have to update the deployment share
System    SMBus                           9.4.0.1023       LxLpSMB.inf    is probably the driver you need the most to see the hard drive

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LA_AdminAuthor Commented:
This did it. I went back and created a WinPEx64 selection group and only put in network and storage drivers (including the one listed above), then after changing the x64 drivers and packages info to the new group (deployment share > properties > Windows PE > Platform (x64) > Drivers and Patches > change selection profile) , I completely rebuilt the boot image. reconnected it, and it is finally humming along. Thank you!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.