Windows 10 PCs lose connection to mapped drives on windows 2008 r2 server

Running a Windows 2008 R2 server with DNS Server running.  NIC on the server set to staic IP address with the DNS pointers going to 75.75.75.75 and 75.75.76.76 (Comcast).
Since converting workstations to Windows 10, they all lose their connection to mapped drives on the server.  Every morning when accessing mapped drives we are prompted "The system cannot contact a domain controller to service the authentication request.  Please try again later.  On that same screen we enter our credentials and are connected to the mapped drives again (for the day).

This is not happening with workstations that are still Windows 7.

Suggestions please.  What have I done wrong?
jhillbosAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SerjTechCommented:
I take it your drives are deployed using GPO's?

If so, take a look in the GPO for mapping your drives, should be located under: User Configuration > Preferences > Windows Settings > Drive Maps, and see if it is set to "Replace". If so change it to "Update" and this should solve the issue.

Replace has been an issue with drive mapping on Windows 8 and Windows 10.

Give it a test and see if it works out.
jhillbosAuthor Commented:
My drives are deployed using login scripts.  Probably should switch to GPO, but not really familiar with the process.
LockDown32OwnerCommented:
I would go in to Credential Manager and delete any stored password for the Domain. They could be corrupt. Also try turning off power management on the network card. Have you checked to see if the computer still has an IP address at that point?
HTML5 and CSS3 Fundamentals

Build a website from the ground up by first learning the fundamentals of HTML5 and CSS3, the two popular programming languages used to present content online. HTML deals with fonts, colors, graphics, and hyperlinks, while CSS describes how HTML elements are to be displayed.

SerjTechCommented:
Well if you are using login scripts then my answer not the solution.

It could be Windows 10 is dropping idle connections.

Take a look at following article and see if this helps:
http://www.thewindowsclub.com/mapped-drive-gets-disconnected
Jackie Man IT ManagerCommented:
Check whether there is an updated driver of network interface card if your win 10 OS.
DonNetwork AdministratorCommented:
I use the script here to disable the "Turn off this device...."

https://gallery.technet.microsoft.com/scriptcenter/Disable-turn-off-this-f74e9e4a
LockDown32OwnerCommented:
OPK. That takes power management out of play. If it happens again do a ipconfig /all on the problem workstation just to see if it has retained the IP settings.
BillBondoCommented:
Why are you using Comcast as your DNS? Thats could be your issue.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LockDown32OwnerCommented:
Good catch Bill. I looked at that and immediately thought forwarders. @jhillbos what Bill just pointed out is a huge mistake. The DNS on the NIC in the server should point to itself. Put the Comcast DNS's in the DNS Server on the Server as Forwarders. It might not fix the issue (it probably will) but it should be corrected.
jhillbosAuthor Commented:
Hello Bill and lockdown

I reset my server NIC so the Preferred DNS server is itself (192.168.1.2) and the Sec DNS Server is 127.0.0.1 and I still have the same problem.

DNS is somewhere that I am really lacking.  Not sure how to set Comcast DNS on the Server as forwarders.

Although I figure it has to have something to do with DNS
LockDown32OwnerCommented:
Good deal jhillbos. It wasn't the cause of the mapping issue but you just corrected a flaw that really needed to be corrected. On that same note. Open the DNS Manager. Right click on the server. Properties. Forwarders TAB. Screen shot attached. I use Comcast tool. I use the two Google Public DNSs as #3 and #4. Don't worry about DNS. Yu don't mess with it that much. You'll pick it up in time.

Back to the issue... do you leave the computer running 24/7? When they are in this state have you checked their IP settings with a ipconfig /all at a command prompt and can you ping the server?
Capture.PNG
LockDown32OwnerCommented:
One more last minute thought along the line of the DNS. What is acting as your DHCP Server? Can up post an ipconfig /all from one of the computers?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.