Solved

Setting up OWA access rule in SonicWall

Posted on 2016-07-15
6
250 Views
Last Modified: 2016-07-19
Hi Guys,

I have difficulty setting up an OWA access rule in SonicWall.

I have SonicWall WAN connection (192.168.1.4)
.. coming from an ADSL router translating internet traffic to 192.168.1.4 -> SonicWall

LAN connection on 10.0.0.240 / 24
Exchange server on 10.0.0.27 / 24

I can't get the access rule / NAT to work:

ACCESS RULE:
From:  WAN
To:  LAN
Source Port:  Any
Service:  Exchange 2013 (http & https)
Source:  Any
Destination:  WAN Interface IP

NAT RULE:
Original Source:  Firewall Subnets
Translated Source:  WAN interface IP
Original Destination:  WAN interface IP
Translated Destination:  Exchange Server (10.0.0.27)
Original Service:  Exchange 2013 (http & https)
Translated Service:  Original
Inboud Interface:  Any
Outbound Interface:  Any

I've tried other configurations as well, but still no joy.

The log monitor has also not been really helpful, perhaps I am using wrong log-filter?
0
Comment
Question by:Rupert Eghardt
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 40

Expert Comment

by:Adam Brown
ID: 41713750
You're basically double NATing from your explanation. Try to get your router running in Bridge mode, so the IP is directly applied at the Sonicwall. Otherwise, you'll also have to set the rule up in your ADSL router as well. (NAT Public IP to SonicWall WAN port IP in Router, NAT Sonicwall WAN Port IP to Exchange server in SonicWall config). You also will want to limit the ports in the NAT rule to ports 443 and 25, since those are the ones that Exchange needs on the Internet.
0
 
LVL 25

Expert Comment

by:Diverse IT
ID: 41713821
Hi Rupert,

It could be double NATing but we'd need to see more details. You could have issues with a 443 conflict. On the surface it isn't obvious but if you have remote management enabled (443 enabled on the WAN Interface) while opening 443 on the WAN > LAN side. I said it is not terribly obvious because you'd typically think to look for open inbound ports on the WAN > LAN Zone not actually realizing management services (ping, management, etc.) run on WAN > WAN. The way to remedy this is to go to System > Administration and change the port next to HTTPS Port: under Web Management Settings.

Let me know how it goes!
1
 

Author Comment

by:Rupert Eghardt
ID: 41714518
Thanks Guys,

The ADSL router is locked by the service provider and can't be edited.
However, traffic from the internet (via the DSL router) is arriving at the SonicWALL router.
I realised this, when the admin page of the SonicWALL was displayed initially.

I changed the SSL port under Web Management settings for the SonicWall, and the admin page is no longer displayed.

This tells me that the 443 traffic is reaching the SonicWall, but not being relayed through to the Exchange server on 10.0.0.27.

Are the access & NAT rules above correct?
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 25

Accepted Solution

by:
Diverse IT earned 500 total points
ID: 41714739
I changed the SSL port under Web Management settings for the SonicWall, and the admin page is no longer displayed.
Perfect this has now unblocked your 443 conflict. From now on when you login, you need to type your Public IP with the new port number you assigned for management, for example https://1.1.1.1:4443. Make sense?

If that is your only NAT policy then no that will not work. You need three NAT Policies: 1) inbound, 2) outbound and 3) loopback policy. I'd remove that you have or both the Access Rule and the NAT policy that you have specifically set up and then go the Wizards link in the top right of the GUI and select Public Server and follow the prompts. That is the best more complete way to open up ports on your SonicWALL. And if the Wizard is not flexible enough for what you want to do...don't worry about it...you can always go back to the Access Rules or NAT policies it has setup and modify them.

Let me know if you have any questions!
1
 

Author Comment

by:Rupert Eghardt
ID: 41718969
Thank you Diverseit,

I've deleted the NAT policy and used the wizard to setup a new set of NAT policies for publishing the server.

The wizard only created 2 x NAT rules, and still did not work.
I logged a call with SonicWALL and we've added a 3rd rule with their assistance. OWA is working ;-)

I encountered a strange problem, possibly a bug in the firmware;
Upon adding NAT rules, "custom rules" option,
Upon moving a rule to position 1, the SonicWALL deletes the rule without a prompt.
I tried a couple of times, the same problem occurred.

I have another server to publish on a different range 192.168.2.x  (SonicWALL on 10.0.0.x)
I've setup a static route, and the SonicWALL can ping the server successfully.
Setting up the same 3 x NAT rules for this server, doesn't work.  

Any ideas?
0
 
LVL 25

Expert Comment

by:Diverse IT
ID: 41719034
Strange. The wizard should always add three rules inbound, outbound and loopback. Did you have the option not to select loopback?

You can leave the priority of the NAT Policies default. I'm not sure I understand the auto-delete NAT policy. What NAT policy are you trying to create that the wizard hasn't already?

Regarding the other server, I'd love to help but it is outside of the scope of this question. Please open a new question and I'll hop on that and answer it for you. Experts Exchange likes to keep a specific question/specific answer so that when users try to find issues they find the answers instead of offshoots, etc. I hope you understand. :)
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
This article will inform Clients about common and important expectations from the freelancers (Experts) who are looking at your Gig.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question