Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

can not format usb drive says write protected

Posted on 2016-07-15
11
Medium Priority
?
142 Views
Last Modified: 2016-07-15
1) there is not a switch on the usb that is write protecting it
2) i have tried diskpart and removing the read only attribute this doesn't work
3) tried to format and this doesn't work

is there a tool out there that is free that will format this usb stick no questions asked?
if so can someone help me or show me how to smoke this usb that wants to stay write protected.
0
Comment
Question by:bbimis
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +3
11 Comments
 
LVL 37

Expert Comment

by:bbao
ID: 41712935
what's name and model of your USB stick? how many partitions are there on the USB drive?
0
 
LVL 97

Assisted Solution

by:John Hurst
John Hurst earned 400 total points
ID: 41712943
Try removing the write protection in Regedit.

http://www.pcadvisor.co.uk/how-to/storage/how-erase-write-protected-usb-drive-or-sd-card-summary-3633096/

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies

See if that allows you to format.
0
 

Author Comment

by:bbimis
ID: 41712953
John thanks for that and I did try and and the value was already set to 0 :(
i thought i seem some utility that was used for the dell sticks that have windows on them that allows you to format them (not what i'm trying to do) but along the same lines
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:bbimis
ID: 41712956
its a standard usb stick has no marking for name. and only one partition
0
 
LVL 97

Expert Comment

by:John Hurst
ID: 41712962
Get a cheap stick and try formatting it. The USB stick you have may have died.
0
 
LVL 36

Accepted Solution

by:
Kimputer earned 400 total points
ID: 41712999
Probably, this USB stick is now a very light paperweight. There are some USB sticks that are prone to have this behaviour (write protected for no reason), and big companies like Transcend, actually have a tool to solve that. It just scans for the drive, identifies it, gets the newest firmware online (even if it was already the newest), rewrites the USB drive, and voila, it's working again (minus all your data, that's been deleted). But obviously, it will only scan it's own devices, and not some unbranded one.
Since yours is unmarked, you can try to identify the exact hardware id (device manager > disk drives > right mouse click on the usb drive > Properties > tab Details > dropdown: hardware ids
Then google if there's a program/fix for that device (probably not)
0
 
LVL 14

Assisted Solution

by:Kaffiend
Kaffiend earned 800 total points
ID: 41713127
The USB drives from Dell that have the OS install media on them?

Yeah, a few generations ago you could have removed the write protection from these things.  It hasn't been possible for a while now.  Unless something has changed recently, it just can't be done.

Google it, you will find many people that have tried .....
0
 
LVL 37

Assisted Solution

by:bbao
bbao earned 400 total points
ID: 41713149
if DISKPART can't erase the drive, I would double check the USB stick and see if any tiny physical RW/RO switch somewhere on the stick. one of my USB stick has such a switch.
0
 

Author Closing Comment

by:bbimis
ID: 41713197
thanks for all the help!
0
 
LVL 97

Expert Comment

by:John Hurst
ID: 41713200
You are very welcome and I was happy to help.
0
 
LVL 30

Expert Comment

by:Thomas Zucker-Scharff
ID: 41713324
Linux is your friend for this.  Just boot to a linux distro format the drive in linux.  Plug the drive into a windows machine and it will ask to format.  The other way around is to use this adapter you can get off amazon to make it into a android readable drive (works with any USB), plug into your phone and format the stick.  Then plug into windows machine and it should either ask to format or be okay with it.
0

Featured Post

Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The business world is becoming increasingly integrated with tech. It’s not just for a select few anymore — but what about if you have a small business? It may be easier than you think to integrate technology into your small business, and it’s likely…
IF you are either unfamiliar with rootkits, or want to know more about them, read on ....
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
Suggested Courses

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question