Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange InternalUrl and ExternalUrl settings

Posted on 2016-07-16
5
Medium Priority
?
251 Views
Last Modified: 2016-09-27
hi

I have just installed a new Exchange 2013 SP1 Server and outlook is giving proxy certificate errors and ssl cert is looking for the local machine name instead of the purchased cert remote.domain.com

I have ran these commands to get current settings:

[PS] C:\Windows\system32>Get-WebServicesVirtualDirectory | Select InternalUrl,BasicAuthenticationExternalUrl,Identity |
Format-List


InternalUrl                    : https://remote.erewash-partnership.com/ews/exchange.asmx
BasicAuthenticationExternalUrl :
Identity                       : EPL-SERVER2012\EWS (Default Web Site)



[PS] C:\Windows\system32>Get-OabVirtualDirectory | Select InternalURL,ExternalURL,Identity | FL


InternalUrl : https://remote.erewash-partnership.com/oab
ExternalUrl :
Identity    : EPL-SERVER2012\OAB (Default Web Site)



[PS] C:\Windows\system32>
[PS] C:\Windows\system32>Get-ActiveSyncVirtualDirectory | Select InternalUrl,ExternalUrl,Identity | fl


InternalUrl : https://epl-server2012.epl.local/Microsoft-Server-ActiveSync
ExternalUrl :
Identity    : EPL-SERVER2012\Microsoft-Server-ActiveSync (Default Web Site)


So to fix I have tried these commands:

Set-ClientAccessServer -Identity "epl-server2012" -AutodiscoverServiceInternalUri https://remote.erewash-partnership.com/Autodiscover/Autodiscover.xml
Set-WebServicesVirtualDirectory -Identity "epl-server2012\EWS (Default Web Site)" -InternalUrl https://remote.erewash-partnership.com/ews/exchange.asmx
Set-OABVirtualDirectory -Identity "epl-server2012\oab (Default Web Site)" -InternalUrl https://remote.erewash-partnership.com/oab 
Set-AutodiscovervirtualDirectory -Identity "epl-server2012\autodiscover (Default Web Site)" -InternalUrl https://remote.erewash-partnership.com/autodiscover/autodiscover.xml
Set-AutodiscovervirtualDirectory -Identity "epl-server2012\autodiscover (Default Web Site)" -ExternalUrl https://remote.erewash-partnership.com/autodiscover/autodiscover.xml
Set-ActiveSyncVirtualDirectory -Identity "Microsoft-Server-ActiveSync (Default Web Site)" -InternalUrl "https://remote.erewash-partnership.com/Microsoft-Server-ActiveSync"

The first 3 seem to do something but the last 3 are giving the following type of errrors!

A parameter cannot be found that matches parameter name 'InternalUrl'.
    + CategoryInfo          : InvalidArgument: (:) [Set-AutodiscoverVirtualDirectory], ParameterBindingException
    + FullyQualifiedErrorId : NamedParameterNotFound,Set-AutodiscoverVirtualDirectory
    + PSComputerName        : epl-server2012.epl.local


Please advise

Ash
0
Comment
Question by:AshGhai
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
5 Comments
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 41714727
If you are going to use the .com FQDN as your INTERNAL URL you need to be sure that you have that domain added as a forward lookup zone in your internal DNS.
0
 

Author Comment

by:AshGhai
ID: 41714875
Hi Jeffrey

I have already added the the forward lookup zone for the domain but I still get the same error?
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 2000 total points
ID: 41717505
Exchange 2013 SP1? Really? You can install from the latest cumulative update. I would suggest that you update before you go any further.

This:

Set-AutodiscovervirtualDirectory -Identity "epl-server2012\autodiscover (Default Web Site)" -InternalUrl https://remote.erewash-partnership.com/autodiscover/autodiscover.xml
 Set-AutodiscovervirtualDirectory -Identity "epl-server2012\autodiscover (Default Web Site)" -ExternalUrl https://remote.erewash-partnership.com/autodiscover/autodiscover.xml

Wasn't necessary.

I have a script that changes what is required here: http://semb.ee/hostnames2013

You must have a trusted SSL certificate on the server that matches, and the internal DNS must resolve to the internal IP address of the server.
They should be set back to null.
0
 

Author Comment

by:AshGhai
ID: 41717923
Thanks Simon, I will try that..

Sorry I had already updated with cu12

Regards
Ash
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
Suggested Courses

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question