Solved

Do not sleep syntax

Posted on 2016-07-16
6
47 Views
Last Modified: 2016-07-17
My OS is win 10 pro 64 bit.  At times whenever I am installing a software, the pc goes into sleep mode or powers off.  I have created the following shortcut which runs, but the monitor still goes to sleep, and also I have to login again.  is the following syntax correct which is on my desktop :
C:\Windows\System32\powercfg.exe -setactive dd36f31e-745c-416d-9958-26cfc61529bf

thank u.
0
Comment
Question by:jegajothy
  • 3
  • 3
6 Comments
 
LVL 94

Expert Comment

by:John Hurst
ID: 41714962
If the command works the syntax is correct, but you want to make sure you are picking out the correct power plan. Also make sure you are open cmd.exe with Run As Administrator to do this.

Run powercfg -l to list the plans and it will list the plan name with it.

Also (and easier) on your Desktop, go to Control Panel, power, pick out your active plan, go to Advanced settings and for "sleep (or suspend"  set suspend and hibernate to Never. Your machine should be able to run 24x7.

If you do not want a black monitor to ask for a password, turn that off in Advanced Power settings as well (in the display section).
0
 

Author Comment

by:jegajothy
ID: 41715714
in response to John, I do not think the syntax works, because the pc still goes to sleep, and the screen turns black, and I have to revive and login into my pc as though I rebooted.  Thank u.
0
 

Author Comment

by:jegajothy
ID: 41715726
in response to John, I have followed your suggestion, and will get back to see if this works. thank u and regards.
0
Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

 
LVL 94

Accepted Solution

by:
John Hurst earned 500 total points
ID: 41715727
You really only need that command (the way you wrote it) to set the power plan. That does not modify the power plan. I think you can ignore the command line approach.

Go to Power Options as I suggested and turn Suspend OFF.

Windows-10-Power-Plan-2
0
 

Author Closing Comment

by:jegajothy
ID: 41716156
Yes, this solution by John works best. Thank u.
0
 
LVL 94

Expert Comment

by:John Hurst
ID: 41716165
You are very welcome and I was happy to help. Thanks for the update that it worked.
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A quick guide on how to use Group Policy to create a custom power plan and set it active on Windows 7.
The Windows functions GetTickCount and timeGetTime retrieve the number of milliseconds since the system was started. However, the value is stored in a DWORD, which means that it wraps around to zero every 49.7 days. This article shows how to solve t…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question