Goldmine One-button Sync with Windows 10

I have Goldmine Premium Edition v 2014.1.0.489 running as a server on my Desktop PC and as a remote on my laptop.

I recently renewed both my Desktop PC and laptop so both are running Windows 10 and One-button Sync no longer works (it used to work well with Win 7 on the Desktop and Win 10 on the laptop).

The error message I get on the laptop is "Unable to establish connection. Timed out waiting for a response. System error 10060".

So, I presume there are security settings or firewall settings that need to be entered or amended on one or both machines (which use Windows Firewall).

So, at the moment I am forced to use the Sync Wizard and when I do, the laptop quite happily creates/retrieves transfer sets on/from the desktop.

Any suggestions?
plumothyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

GMGeniusSoftware Development Manager/DeveloperCommented:
Hi again,

Has your Desktop PC (Server) name changed?

How did you transfer the One Button sync setup to the new Laptop or did you create a new One Button sync setup and install a fresh on the new Laptop
plumothyAuthor Commented:
Yes, the Desktop PC name did change. However, when I created a new One Button Sync setup, I think I told it to use the fixed IP address of the server rather than its name.
GMGeniusSoftware Development Manager/DeveloperCommented:
Have you re-setup the Sync monitoring on the new Desktop?

have you tried turning off the firewall on the Desktop so you can then eliminate the firewall

if the sync service is not running on the desktop then the sync will fail to connect because nothing is listening
Become a CompTIA Certified Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

plumothyAuthor Commented:
Yes, the sync service is running on the desktop so it is "listening" for the laptop.

No, I haven't tried turning off the desktop firewall. I will try this when I get back to my office (which will be at the end of the week) and let you know the result.

Thank you for your assistance so far.
plumothyAuthor Commented:
Back at my desk at last.

Unfortunately, turning off the firewall on the desktop has not cured the issue.

However, the error message is now different:
"3[2-0] Unable to establish connection.
3[2-0] Connection refused: System error 10061.
3[2-0] Possible causes:  no Internet connection, host is unreachable, GoldSync is not listening, or host and remote are not set to the same port."
GMGeniusSoftware Development Manager/DeveloperCommented:
This tells me that the laptop sync settings must be wrong, the server name/ ip address set for the setup must have been set incorrectly

The log should show the server the sync is trying to connect to, can you post a screen shot of the actual log with everything in it

How is this setup

One button sync or sync wizard?
plumothyAuthor Commented:
Here are the last few lines of the log:
0[2-0] All documents compressed successfully.
1[2-0] Transfer set created successfully.
0[2-0] Compressing transfer set...
0[2-0] Transfer set: TSAA0047.gts compressed successfully.
0[2-0] Connecting to 192.168.2.60 - 5993...
3[2-0] Unable to establish connection.
3[2-0] Connection refused: System error 10061.
3[2-0] Possible causes:  no Internet connection, host is unreachable, GoldSync is not listening, or host and remote are not set to the same port.
0[2-0] Sync Task  [Ended 16:48 - 24/07/2016; Dur: 0:07]
0[1] Sync-Wizard Process  [Ended 16:48 - 24/07/2016; Dur: 0:07]


I have checked - my server (ie the desktop PC) does have IP address 192.168.2.60 (static). I presume 5993 is a port number.

I'm not sure about the answer to your final question. I clicked on the One Button Sync button.
GMGeniusSoftware Development Manager/DeveloperCommented:
ok,

To test if the server is contactable outside of GoldMine

open a command prompt on the laptop and type  in

TELNET 192.168.2.60:5993

the screen should go blank if it can connect

On the PC/Server do the same but type in TELNET 127.0.0.1:5993

If this goes blank and the first does not then its being blocked, if the server/PC does not work then its the sync service

on the PC/Server , is the sync agent running?

Does the setup look like the attached file?
Capture.JPG
GMGeniusSoftware Development Manager/DeveloperCommented:
I am pretty sure your PC/Server is not setup correctly to listen , either not running at all or not on the correct IP/Port
plumothyAuthor Commented:
Once again, I am away from my office so I cannot try Telnet on the laptop for a few days. However, I was able to run it on the desktop remotely and got this result:
Connecting To 127.0.0.1:5993...Could not open connection to the host, on port 23: Connect failed

I think the attached image shows my server is running and listening on port 5993. Also, I can see it running in the Services tab of Task Manager.
Server.jpg
plumothyAuthor Commented:
Sorry, I forgot to say that, yes, my setup does look exactly like your attached image.
GMGeniusSoftware Development Manager/DeveloperCommented:
Apologies,

Should be Telnet 127.0.0.1 5993 < space not :

and 192.168.2.60 5993
plumothyAuthor Commented:
OK. The desktop/server now give this message from Telnet:
"Connecting To 127.0.0.1...Could not open connection to the host, on port 5993: Connect failed"
GMGeniusSoftware Development Manager/DeveloperCommented:
That means its the desktop thats the issue

Are you sure the Sync Agent is running?

Is it installed as a service?
plumothyAuthor Commented:
Is this it?
GMService.jpg
GMGeniusSoftware Development Manager/DeveloperCommented:
Please do the following on the PC

Open GoldMine, navigate to Tools > Services > Manager Server Agents

choose the Goldsync tab and tick "apply to all users" and tick all the Active Period boxes

Disable the Sync Service and then in GoldMine Tools > Services > Start Server Agents

You should see something like the attached. Capture.jpg

now try the Telnet command

now it should show the second attachment Capture1.jpg

if its not then show me
Capture.JPG
Capture1.JPG
plumothyAuthor Commented:
I was OK until your instruction:
"Disable the Sync Service"

I'm not sure how to do that. I could not see any "Disable Sync Service" option in GM or a "Disable" option for the GoldSync Service in Task Manager/Services.

So, I stopped the service in Task Manager/Services and continued with your instructions.

But, after "GoldMine Tools > Services > Start Server Agents" and retrying the Telnet command (which gave the same error message as before), I got the attached image.
AfterStartingAgents.jpg
GMGeniusSoftware Development Manager/DeveloperCommented:
Hi

Your sync is not setup correctly and is not listening at all

Is our desktop called PLUM?

I suspect you have not ticked an option

Tools > Synchronize > GoldSync Administration

Expand the servers and double click on the IP to IP/Network: Accept incoming connections

Click next until you see the page in the attached.  tick it and try again

stopping the service was what I meant anyway :)

If this is not ticked GoldSync will do nothing

If the connection works you can sync from the laptop and leaving the task windo open you can monitor it

once your happy, close GM and restart the service
Capture.JPG
plumothyAuthor Commented:
Is our desktop called PLUM?
- Yes

Tools > Synchronize > GoldSync Administration

Expand the servers and double click on the IP to IP/Network: Accept incoming connections

Click next until you see the page in the attached.  tick it and try again
- that page already looks exactly as your attached image. By "it" I presume you mean the "Start this sync process automatically..." check box. It is already ticked (and always has been).

The sync service shows in both GM and Task Manager that it is running and it is set to listen on port 5993, but Telnet still gives the usual error. I am beginning to think this is never going to work. But it used to work when the server was a Win 7 PC. Maybe it simply does not work on Win 10.

Is there a way of setting up One-Button Sync from scratch that does not require re-installation of Goldmine?
GMGeniusSoftware Development Manager/DeveloperCommented:
Did you follow my previous comment

Open GoldMine, navigate to Tools > Services > Manager Server Agents

 choose the Goldsync tab and tick "apply to all users" and tick all the Active Period boxes <<<<<<<<<<<

your screen shot before did not show the server agent start to listen as it should which is why I believe its a config issue
plumothyAuthor Commented:
Yes, I have done everything that you suggested.

Even though we have set GM to start the sync service when GM launches, that does not happen. But even if I start the service myself, Telnet still gives the "Connect failed" error.

So, we have ensured that GM and the service are correctly configured but it still does not work.

This is why I wonder if it is simply not compatible with Win 10.
GMGeniusSoftware Development Manager/DeveloperCommented:
I have a windows 10 Virtual machine , I will test this out

It would be easier if I could take a look at this via a remote session to the PC

Can we arrange this, then post my findings here

Let me know if convenient to do so.
plumothyAuthor Commented:
I am out of the office for a few days, but will be in on Friday, UK office hours.

I have Team Viewer but can install another one if required.
GMGeniusSoftware Development Manager/DeveloperCommented:
TeamViewer is perfect
plumothyAuthor Commented:
Back in my office. I have made a little progress.

On the server/desktop I deleted the "IP to IP/Network Accept incoming remote connections" process and created a new one. Now I do get a blank screen with Telnet (from both desktop and laptop) and the GM process monitor showed those connections.

On the server/desktop I deleted the Laptop Site and re-created it from scratch, which included creating a new One-button Sync Profile. I emailed that profile to the laptop. On the laptop I successfully received that profile.

However, when I click on "One-button Sync with Goldmine Server" I am told "You do not have a One-button Sync Profile to synchronize with a GoldSync Server".

So, I'm nearly there - just need to get the profile onto the laptop, then it should work.

Perhaps you have a suggestion to fix that and we don't need a remote Team Viewer session?
GMGeniusSoftware Development Manager/DeveloperCommented:
Are you logged into the Laptop with the correct username the one button profile was created for?
plumothyAuthor Commented:
Do you mean the GM user name? If so, then yes, they are the same on each machine: "STEVE"

(The two computers have different Windows user names).
GMGeniusSoftware Development Manager/DeveloperCommented:
The message you are getting indicates the one button sync received is not correct for the undocked user

Perhaps your license code for the undocked user is the old one?

Try

Rename license.bin on the laptop and re-create the license code on the server and when you open the laptop it should prompt to insert the license code

then try again
plumothyAuthor Commented:
OK, I have done that (I didn't have a license.bin file, but I did have LicenseGM.bin).

The laptop still tells me "You do not have a One-button Sync Profile to synchronize with a GoldSync Server". This is after emailing myself and receiving a new one-button profile.
GMGeniusSoftware Development Manager/DeveloperCommented:
Hopefully you have access to MSSQL Management studio

dump the contents of these two tables and post here


         SELECT * FROM GSSERVER
         SELECT * FROM GSSITES

both on the server and the laptop
plumothyAuthor Commented:
OK. Here they are from the laptop
GSSERVER.csv
GSSITES.csv
plumothyAuthor Commented:
And here they are from the Desktop
GSSERVER.csv
GSSITES.csv
GMGeniusSoftware Development Manager/DeveloperCommented:
I cannot tell what might be wrong unfortunately

I fell this is too complicated to resolve without taking a look directly

If you don't feel confident however I understand
plumothyAuthor Commented:
GM Genius,

Thank you for your assistance so far - I really appreciate your efforts (and I have learned a bit about GM along the way).

I am going to try to completely re-install GM on my laptop but it will be a few days before I get the time to do it.

I will post the results when done.
GMGeniusSoftware Development Manager/DeveloperCommented:
Hi,

You really shouldn't need to, I don't think it will help,

If anything , remove all undocked users, remove all Goldsync settings and start that process again

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
plumothyAuthor Commented:
OK, thanks. I will try that first!
GMGeniusSoftware Development Manager/DeveloperCommented:
Have you gotten any further with this?

It would be good to show a resolution for this.  I can still offer a remote session to diagnose / resolve if you so wish
plumothyAuthor Commented:
My problem is time. I have been out of my office for the last 2 weeks and will be for 4 of the next 5 weeks.

So I'll have to carry on using the synchro wizard for now.
plumothyAuthor Commented:
After a very long time, here is an update.

Today I was forced to rebuild my laptop. Of course, this meant reinstalling Goldmine on it from scratch.

Now, One-button Sync works again!

So, I am happy but I have no idea what caused the original issue!

Many thank to GMGenius for all of your input. Points to you.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Contact Management

From novice to tech pro — start learning today.