Solved

RemoteApp certificate problem Windows 2102 R2

Posted on 2016-07-17
5
25 Views
Last Modified: 2016-07-23
I have enabled RemoteApps on a Windows 2102 R2 RDS server.

From a Win7 client all works well if I use a browser to access the RDS server, manually install the (self signed) certificate and use the remote-apps.

However,  on the same client, when I try to add the remote-apps through Control Panel > RemoteApp and Desktop Connections wizard I keep getting a certificate error. (below)
 
certerror
* I have installed the (self signed) certificate into the Trusted Root Certification Authorities on the Win7 client.

Any help would be greatly appreciated.

thanks
0
Comment
Question by:matedwards
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
5 Comments
 
LVL 80

Expert Comment

by:David Johnson, CD, MVP
ID: 41716184
you also have to add the certificate to the MACHINE store
0
 

Author Comment

by:matedwards
ID: 41716317
I have installed the (self signed) certificate into the Trusted Root Certification Authorities on the Win7 client.
I used the certificates mmc to add it to computer.
0
 

Author Comment

by:matedwards
ID: 41717045
I've also spotted this error when connecting via a browser.

certificate error
I believe the error could be becasue my certificate name  does not exactly  match the name of my RDS server.
0
 

Accepted Solution

by:
matedwards earned 0 total points
ID: 41717051
In the link below

http://www.rdsgurus.com/ssl-certificates/windows-2012-r2-how-to-create-a-mostly-seamless-logon-experience-for-your-remote-desktop-services-environment/

I spotted this line -  You know the name on the certificate must match the name RD Connection Broker uses to identify itself.

I had created a new certificate called remoteapp.domain.local where as the FQDN of my RDS server is rds.domain.local.

So, I created a cname alias in my domain DNS that points remoteapp.domain.local to rds.domain.local.

Now, when I enter https://remoteapp.domain.local/RDWeb/Feed/webfeed.aspx into the Remote Apps control panel the wizard works.

My Remote Apps are appearing in my Progams menu.

thanks for all your help.
0
 

Author Closing Comment

by:matedwards
ID: 41725740
Reason provided above.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
EXCH2013 IIS 4 29
Server 2012 ADMX 1 22
Move the SYSVOL and NTDS folder to another drive 5 34
Keeping 2  Windows 2012 R2 servers  in Sync 4 35
My GPO's made for 2008 R2 servers were not allowing me to RDP into a new 2012 server by default.  That’s why I tried to allow RDP via Powershell, because I could log into a remote shell without further configuration. Below I will describe how I wen…
OfficeMate Freezes on login or does not load after login credentials are input.
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
In this Micro Tutorial viewers will learn how to restore single file or folder from Bare Metal backup image of their system. Tutorial shows how to restore files and folders from system backup. Often it is not needed to restore entire system when onl…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question