Solved

Server 2008 R2 - keyboard and mouse will not respond at logon screen

Posted on 2016-07-17
15
52 Views
Last Modified: 2016-11-22
Dell Poweredge T320 with Windows server 2008 r2 was running find. Installed Microsoft updates and rebooted and now keyboard and mouse will not respond at logon screen. This is the domain controller for the office. This is a RAID 5 configuration and I have checked and the RAID is recognized and working properly.

There are only USB ports - no PS/2.
I can ping the server from a workstation using IP address but not with UNC name.
I cannot RDP into the server using either the IP or UNC name.
At the login screen there is intermittently lots of activity on the hard drive lights.
During boot up the KB and mouse are active and the lights on KB and LED light on mouse are lit.

I have tried:
1) different KB and Mouse but same results
2) have tried booting into safe mode but same results
3) have tried booting last known good but same results
4)have tired adding second KB and mouse to front USB ports but same results.
5)I have looked at the BIOS and the USB ports are all activated and I can use the KB and mouse normally when in BIOS.

I have a nightly windows server backup on external USB drive but I do not think that the drive will be recognized. I guess I could install a fresh copy of the OS and if it sees the USB devices then do a restore from that. However I would like to know if there is some other way to get this to work and most curiously what caused it to happen.

Any help would be appreciated.
0
Comment
Question by:dashman
15 Comments
 

Author Comment

by:dashman
ID: 41715958
One more thing. I just rebooted and watched the lights on the KB and mouse. They are on during the bootup until I get the Windows "splash screen" with the bars going across the screen. As soon as that starts then the KB and mouse become inactive.

Also if I leave the login screen on for a period of time the monitor goes dark but all I have to do is touch the power button and I get the login screen back.
0
 
LVL 11

Expert Comment

by:Scott Gorcester
ID: 41715998
You might attempt to access the event logs and the registry from a remote computer to see if you can determine exactly what caused the issue. I would search this issue online to see what others have done as there are lots of postings with similar issues. One poster said they performed a system restore using the installation CD and they were able to get their server back and running. You may even want to open a support case with Microsoft and since it was Windows updates that caused the issue see if they will waive the fee.

Good Luck!

Scott
0
 

Author Comment

by:dashman
ID: 41716023
i am unable to access the server remotely because as stated I cannot connect via RDP so I cannot see the event log or registry.

I have never had Microsoft wave a fee.

I tried a system restore from the dvd and it says that it is an incorrect type of installation or something similar and will not let me continue.

I have just reinstalled the OS through the Life cycle controller and trying to restore the Bare Metal Backup from the previous night. However it asks which volume you want to restore and I choose C and then where do you want to restore it to and it only gives me the options for the other partitions that all contain data. Not sure how to direct it to the C drive. Do you?
0
 
LVL 11

Expert Comment

by:Scott Gorcester
ID: 41716053
Not sure without understanding more details about your backup. When you say you have reinstalled the OS did you attempt to upgrade or did you overwrite the existing OS? It may be that you are beyond the point of recovering your AD unless you have a second domain controller. It may be possible to install a new OS recreate your AD and recover the data that is on other partitions, again this may depend on the condition of the partitions and the data that is or was on them.

I have had Microsoft waive the fee many times but it may be that option is for Partners, we use the Business Critcal Outage option for support. In one case I paid for support on behalf of a client and the tech later waived the fee due to proof that the update had caused this issue, It may have been worth giving MS the chance to recover your AD before you proceeded but I understand support can be expensive.

Scott
0
 

Author Comment

by:dashman
ID: 41716056
When I try to do the system restore I get the error message:

The version of system restore recovery options is not compatible with the version of windows you are trying to repair. Try using a recovery disc that is compatible with the version of windows.

Some quick research shows something about UEFI vs BIOS. Know anything about that?
0
 
LVL 38

Expert Comment

by:Adam Brown
ID: 41716071
You can connect to event logs remotely without RDP. Just go to event viewer on another system, right click event viewer, select connect to another computer.

That said, check your BIOS to see if there are options for how the USB ports are connected.

UEFI is a modern BIOS system that works better with modern OSes. There may be some settings in UEFI that don't expose things properly to the OS, so updating the BIOS may help.

Also, the system may not be responding because it I attempting to install new USB drivers. Unplug your keyboard and mouse and use a different port, then wait at least 5 minutes after boot before trying the keyboard or mouse. That gives the system time to install the software.
0
 

Author Comment

by:dashman
ID: 41716255
I was unable to connect to the server's event viewer from another computer as no workstation could see the server. I guess it had not completed it's boot although it was at the login screen. I did try this on another computer and the option to connect to another computer was not there. I had to run as administrator and then click on view and then the option was there.

I did check the BIOS and there were no options on how the USB ports were connected.

I did go into the UEFI boot options and I was able to choose BIOS boot. I was then able to get into the restore screen and begin a restore from the Bare Metal backup I had from the night before. However when I got to the last phase to start it the restore it said that I had booted from BIOS and it could not run. Kind of a catch 22.

I had previously followed the steps you outlined for a different port for the KB and mouse but it did not work. I do think that the Microsoft update corrupted the drivers for the USB ports but I could not find a way to restore them.

I ended up reinstalling the OS and then installing BackupExec and restoring the C drive and Shadow copy from a backup up of C and then booting into DSRM and restore the system state from the same backup. I got everything back to the way it was before the Microsoft update and at this point am very hesitant to run those updates again. If I could find a way to restore from the bare metal backup it would be much easier and quicker. This took me hours to try and find a solution to the KB and mouse and then when that did not work run process outlined above.

Thanks everyone for your input. If you think of something else pertinent to this please let me know.
0
Why spend so long doing email signature updates?

Do you spend loads of your time carrying out email signature updates? Not very interesting are they? Don’t let signature updates get you down. Let Exclaimer Cloud - Signatures for Office 365 make managing email signatures a breeze.

 
LVL 55

Expert Comment

by:andyalder
ID: 41716980
Try connecting to it via iDRAC.
0
 

Author Comment

by:dashman
ID: 41717057
Client is a nonprofit with very little money and chose not to get the iDRAC license.
0
 
LVL 16

Expert Comment

by:Gerald Connolly
ID: 41717114
It sounds like the USB ports are being disabled by Windows.

When did all this start? have some global security options been turned on?

Or an access control system like Lumension been installed?
0
 
LVL 14

Expert Comment

by:Michael Dyer
ID: 41717587
You might want to set up the server to accept an RDP session so if this happens again you can access it remotely from another computer on the LAN.  That way, you could install the windows updates and then log in and troubleshoot the issue.
0
 

Author Comment

by:dashman
ID: 41717621
RDP was turned on but the server was not accessible through it. The only thing that could reach it was pinging the IP address. Otherwise it was not "available". Just got off the phone with Dell and hopefully my client will agree to purchase an IDRAC module and license.
0
 

Accepted Solution

by:
dashman earned 0 total points
ID: 41717627
Gerald,

I agree as this started after reboot after Microsoft updates installed. No changes or apps installed, just the updates. I wish I knew what caused it but because my only option was to reinstall OS and restore from Backup Exec backups, the event logs are gone. Just hope it does not happen again.
0
 
LVL 34

Expert Comment

by:Seth Simmons
ID: 41784416
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Why spend so long doing email signature updates?

Do you spend loads of your time carrying out email signature updates? Not very interesting are they? Don’t let signature updates get you down. Let Exclaimer Cloud - Signatures for Office 365 make managing email signatures a breeze.

Join & Write a Comment

Learn about cloud computing and its benefits for small business owners.
Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now