Solved

Apache ignoring ssl config

Posted on 2016-07-18
3
52 Views
Last Modified: 2016-07-25
I have a centos 7 server running apache.

All of a sudden the site is not configured using the ssl certificate.

It is using the locahost certificate and thus making the site insecure.

I have checked my apache config (below) and all looks fine.

This one really does have me stumped as it was working fine.

The only error i can see is
[Mon Jul 18 10:56:15.299743 2016] [ssl:warn] [pid 1377] AH01909: RSA certificate configured for domain.com:443 does NOT include an ID which matches the server name


<VirtualHost 1.1.1.1:80>
      ServerName domain.com
       DocumentRoot /var/www/html/domain.com/live/httpdocs/
</VirtualHost>

<VirtualHost 1.1.1.1:443>
      ServerName domain.com:443
       DocumentRoot /var/www/html/domain.com/live/httpdocs/
        SSLEngine on
        SSLCertificateFile /etc/pki/tls/certs/domain.com.crt
        SSLCertificateKeyFile /etc/pki/tls/private/domain.com.key
      SSLCertificateChainFile /etc/pki/tls/certs/domain.com.ca-bundle
      SSLProtocol all -SSLv2 -SSLv3
      SSLCipherSuite "EECDH+ECDSA+AESGCM EECDH+aRSA+AESGCM EECDH+ECDSA+SHA384 EECDH+ECDSA+SHA256 EECDH+aRSA+SHA384 EECDH+aRSA+SHA256 EECDH+aRSA+RC4 EECDH EDH+aRSA RC4 !aNULL !eNULL !LOW !3DES !MD5 !EXP !PSK !SRP !DSS !RC4"
      SSLHonorCipherOrder on
</VirtualHost>
Capture.JPG
0
Comment
Question by:timb551
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 19

Expert Comment

by:Peter Hutchison
ID: 41717213
Check that the certificates are copied ok to /etc/pki/tls/certs and the permissions are set to allow read from the system.

You can view the certificate file to see if it is the correct one and that is has not expired.

e.g.
openssl x509 -in /etc/pki/tls/certs/domain.com.crt -inform pem -noout -text
0
 

Accepted Solution

by:
timb551 earned 0 total points
ID: 41717263
checked all that and its fine.

For some reason it seems to be taking the config from the ssl.conf file rather than the httpd.conf file.

I have altered the ssl to include the sites certs and its working now but i dont know why a server that hasnt been touch would have changed its setup.
0
 

Author Closing Comment

by:timb551
ID: 41727378
ssl.conf was taking precedence over httpd.conf

Added ssl to ssl.conf and all started working.
0

Featured Post

Building an interactive eFuture classroom

Watch and learn how ATEN provided a total control system solution including seamless switching matrix switch, HDBaseT extenders, PDU, lighting control to build an interactive eFuture classroom.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
It is possible to boost certain documents at query time in Solr. Query time boosting can be a powerful resource for finding the most relevant and "best" content. Of course the more information you index, the more fields you will be able to use for y…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question