Solved

DHCP on the Switch not working

Posted on 2016-07-18
5
15 Views
Last Modified: 2016-07-18
I have no idea why I cannot get this to work. I was hoping someone can help out. I configured a very simple topology. ESW1 is running DHCP. I pasted all configs. Can anyone see why I can't get IP on the R1 host? I also pasted debug on ESW1. I dont know why it says "DHCPD: there is no address pool for 192.168.0.1"2016-07-18_13-46-42.jpg
ESW1
ESW1#SHOW RUN
Building configuration...

Current configuration : 2967 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ESW1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
ip dhcp use vrf connected
!
ip dhcp pool v10
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!

!
!
macro name add_vlan
end
vlan database
vlan $v
exit
@
macro name del_vlan
end
vlan database
no vlan $v
exit
@
!
vtp file nvram:vlan.dat
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 description *** Unused for Layer2 EtherSwitch ***
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description *** Unused for Layer2 EtherSwitch ***
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 duplex full
 speed 100
!
interface FastEthernet1/1
 switchport mode trunk
 duplex full
 speed 100
!

interface Vlan1
 ip address 192.168.0.1 255.255.255.0
!
ip forward-protocol nd
ip route 10.10.10.0 255.255.255.0 192.168.0.2
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!

!
control-plane
!

!
!
banner exec ^C

***************************************************************
This is a normal Router with a Switch module inside (NM-16ESW)
It has been pre-configured with hard-coded speed and duplex

To create vlans use the command "vlan database" in exec mode
After creating all desired vlans use "exit" to apply the config

To view existing vlans use the command "show vlan-switch brief"

Alias(exec)     : vl   - "show vlan-switch brief" command
Alias(configure): va X - macro to add vlan X
Alias(configure): vd X - macro to delete vlan X
***************************************************************

^C
alias configure va macro global trace add_vlan $v
alias configure vd macro global trace del_vlan $v
alias exec vl show vlan-switch brief
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login

Open in new window


ESW2
ESW2#SHOW RUN
Building configuration...

Current configuration : 2940 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname ESW2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
macro name add_vlan
end
vlan database
vlan $v
exit
@
macro name del_vlan
end
vlan database
no vlan $v
exit
@
!
vtp file nvram:vlan.dat
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 description *** Unused for Layer2 EtherSwitch ***
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description *** Unused for Layer2 EtherSwitch ***
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 switchport access vlan 10
 duplex full
 speed 100
!
interface FastEthernet1/1
 switchport mode trunk
 duplex full
 speed 100
!
!
interface Vlan1
 ip address 192.168.0.2 255.255.255.0
!
interface Vlan10
 ip address 10.10.10.1 255.255.255.0
 ip helper-address 192.168.0.1
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!

!
control-plane
!
!
!
banner exec ^C

***************************************************************
This is a normal Router with a Switch module inside (NM-16ESW)
It has been pre-configured with hard-coded speed and duplex

To create vlans use the command "vlan database" in exec mode
After creating all desired vlans use "exit" to apply the config

To view existing vlans use the command "show vlan-switch brief"

Alias(exec)     : vl   - "show vlan-switch brief" command
Alias(configure): va X - macro to add vlan X
Alias(configure): vd X - macro to delete vlan X
***************************************************************

^C
alias configure va macro global trace add_vlan $v
alias configure vd macro global trace del_vlan $v
alias exec vl show vlan-switch brief
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

Open in new window

0
Comment
Question by:Shark Attack
  • 2
  • 2
5 Comments
 
LVL 1

Author Comment

by:Shark Attack
ID: 41717678
thought I share this too:

ESW1#show ip int br | ex un
Interface                  IP-Address      OK? Method Status                Protocol
Vlan1                      192.168.0.1     YES manual up                    up

ESW2#show ip int br | ex un
Interface                  IP-Address      OK? Method Status                Protocol
Vlan1                      192.168.0.2     YES manual up                    up
Vlan10                     10.10.10.1      YES manual up                    up

ESW2#show int tr

Port      Mode         Encapsulation  Status        Native vlan
Fa1/1     on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa1/1     1-4094

Port      Vlans allowed and active in management domain
Fa1/1     1,10

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/1     1,10

Open in new window

0
 
LVL 3

Expert Comment

by:lifetech
ID: 41717679
with the command "no service dhcp" command in there the helper address wont work. If you take that out should work.
0
 
LVL 3

Accepted Solution

by:
lifetech earned 500 total points
ID: 41717681
On ESW2, change it from no service dhcp to service dhcp.
0
 
LVL 24

Expert Comment

by:Ken Boone
ID: 41717695
Well normally the DCHP scope on the switches is contained where the layer 3 vlan interface is located.  I see no reference to vlan 10 at all on ESW1.  I see you built a scope but you can build a hundred scopes it doesn't tie them to anything.

I don't do much with the ESW switches, but I am "guessing" they don't receive DHCP relays.  They can definitely send a DHCP relay, but I don't think they can receive a DHCP relay.  I could be wrong here.

Anyway it looks like you are trying to set up a trunk here between the switches.  A trunk forwards vlan data between two switches - only for vlans that they both know about.  In this case, it looks like vlan 10 is not configured on ESW1.  What I would do is define vlan 10 on ESW1 and then move the layer 3 interface from ESW2 to ESW1.  This way the client DHCP broadcast request from the router will be trunked across to ESW1 and then ESW1 will know that the broadcast it receives from the router on the interface vlan 10 has a scope assigned to it since the DHCP pool is defined with the same network as the vlan 10 layer 3 interface.
0
 
LVL 1

Author Comment

by:Shark Attack
ID: 41717709
well, i enabled dhcp on SW2 and it works. i thought that only esw1 should be running dhcp
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Suggested Solutions

This article is a step by step guide on how to create a basic PTP link using Ubiquiti airOS devices. This guide can be used on the following Ubiquiti AirMAX devices. Nanostation, Bullets, AirBridge, Nanobeam, NanoBridge to name a few. Please review …
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now