Excel macros not executing in multi Citrix environment

We have an Excel workbook (Excel 2013) on a Citrix XenApp 6.5 server (server A), which has a lot of macros.

When we access from a PC running the latest Citrix receiver we have no problems.  The macros take about 1.5 mins to execute.

However, some of our users have an internal Citrix environment (server B) from which they access the server A.  They access Server B using Citrix receiver 4.2.0.10

Intermittently these users (Server B to Server A connection) experience an issue where the macros in the workbook stop working (or possibly work so slowly that after several hours there is no activity).

I know there is a similar issue when XenApp 6.5 is accessed directly from a pre version 3.2 Citrix Receiver.

Has anyone experienced similar or can point us in the right direction

TIA

Martyn
LVL 1
isenseAsked:
Who is Participating?
 
Tony JConnect With a Mentor Lead Technical ArchitectCommented:
Hi Martyn

I am not aware of any Excel / Macro issues with the 4.2 Receiver. Is there any way you could upgrade one server to the latest version to see if it cures the problem?

In the interim you could try server-to-server access via RDP for a test user rather than Receiver as this would rule out Receiver being the problem.
0
 
isenseAuthor Commented:
Tony

Thanks for your response.

It turns out that server A has a version 3 receiver which it uses to talk to server A, even though the end user is using version 4.2.0.10

We are now in the process of updating server B
0
 
Tony JLead Technical ArchitectCommented:
Hang on...so where I specifically said..."Is there any way you could upgrade one server to the latest version to see if it cures the problem?" and this turned out to be the issues, you still feel the need to not award me points?
0
 
isenseAuthor Commented:
Problem found
0
All Courses

From novice to tech pro — start learning today.