Remote Desktop help needed

Good Afternoon, here is my current setup. I am running a windows server 2012 R2 as a DC inside VM. I have another box that is running server 2012 R2 also and joined to the domain. I am able to establish remote desktop connection and navigate around. But when a user needs to change their password they get this error, Unable to update the password. The value provided for the new password does not meet the length, complexity, or history requirements of the domain. The GPO for this domain currently does not have and password restrictions.

Does anyone have any idea on what might be wrong?
dmbonilla4Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Britt ThompsonSr. Systems EngineerCommented:
Unless you've disabled all the default password complexity settings for the domain there is likely some restrictions within the default domain or default domain controllers GPOs. If you've set these to not configured then the terminal server's local password policy may be generating the complexity requirements.
dmbonilla4Author Commented:
ok Thanks for the quick response, but where do I go to check the terminal servers local password policy?
Britt ThompsonSr. Systems EngineerCommented:
from the terminal server open gpedit.msc and find Computer Configuration > Windows Settings > Security Settings > Account Policies > Password Policy

It's the same path from the default domain GPOs where these restrictions will be configured. I would confirm 100% from your domain GPOs using the Group Policy Management Console that this isn't configured there before altering it on the member server side.
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

dmbonilla4Author Commented:
Thanks for the help. I figured out what the problem was. With my GPOs I didn't have anything set for password policies but on the computer it shows that I have to wait 24 hours since my last password change. I ran the command net user /domain username. Any ideas on why is it doing that?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Britt ThompsonSr. Systems EngineerCommented:
Doing what? Requiring 24 hours? If so, just set the minimum password age to 0 if you don't want that option.
dmbonilla4Author Commented:
I figured the solution out on my own.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.