Solved

ESXi NTP client time synch is not working

Posted on 2016-07-19
3
164 Views
Last Modified: 2016-07-19
Problem: ESXi 5.5 NTP client is not getting NTP time from a Windows Server 2008 R2 that is set up as a NTP server via registry configuration. The NTP server configuration goes something like this here .

Firstly, here is the ntp.conf:
/etc/ntp.conf
Same problem if I use version 2 or if I specify no version at all.
Now I restart the ntpd service and check the log:
/etc/init.d/ntpd restart
Then I check the ntp synch and the system time.
ntpq -p
Obviously, the offset is huge and it is not getting better.

When I try synching time with Windows clients using w32tm /resync /force with the same NTP server as configured above, all works fine. I have tested by changing the time on the server, then synching the clients to the server. But this fails for the NTP client on the ESXi.

I tried disabling the firewall on the ESXi:
esxcli network firewall set --enabled false

Open in new window


Checked that the Firewall on the Windows 2008 R2 server was off in all its profiles.
Tested pinging the NTP server, it replied.

Everything should be OK, but the time is not synching on the ESXi.

Here is how looks like via the vSphere client:
vSphere client time settings
Any suggestions?
0
Comment
Question by:itnifl
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 121
ID: 41719840
have you tried an internet time source ?
0
 
LVL 10

Accepted Solution

by:
Richardson Porto earned 500 total points
ID: 41720095
There are some issues to sync time between ESXi and Windows Server NTP servers, and some workaround are provided on the following KB article: https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1035833

Have you already checked that KB ?
0
 
LVL 2

Author Closing Comment

by:itnifl
ID: 41720227
Yes, I was missing 'tos maxdist 30' in /etc/ntp.conf
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A safe way to clean winsxs folder from your windows server 2008 R2 editions
Giving access to ESXi shell console is always an issue for IT departments to other Teams, or Projects. We need to find a way so that teams can use ESXTOP for their POCs, or tests without giving them the access to ESXi host shell console with a root …
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…

635 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question