Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Mailbox unavailable. The server response was: 5.7.1 Unable to relay - Sending email to Exchange HT/CAS behind Windows NLB

Posted on 2016-07-19
7
Medium Priority
?
474 Views
Last Modified: 2016-08-04
Hi All,

I'm having problem with my server sending email out to external recipient.

Here's my details of Exchange 2010 VMs:

smtp.domain.com - 10.1.1.89 [WIndows NLB for load balancing the HT&CAS servers]
PRODMAIL01-VM - 10.1.1.90 [Hub Transport & Client Access Server]
PRODMAIL02-VM - 10.1.1.91  [Hub Transport & Client Access Server]

When I execute the below Powershell code from the server, the results are varying:


Send-MailMessage -From "sender@server.domain.com" -To "external-recipient@gmail.com" -Subject "Testing email relay using SMTP FQDN address" -Body "This is the body of email..." -SmtpServer "smtp.domain.com" -DeliveryNotificationOption OnFailure -Verbose

Result: Send-MailMessage : Mailbox unavailable. The server response was: 5.7.1 Unable to relay

But when I modify tthe SMTP server to use the HT/CAS server name, all is good:

Send-MailMessage -From "sender@server.domain.com" -To "external-recipient@gmail.com" -Subject "Testing email relay using SMTP FQDN address" -Body "This is the body of email..." -SmtpServer "PRODMAIL01-VM.domain.com" -DeliveryNotificationOption OnFailure -Verbose
and
Send-MailMessage -From "sender@server.domain.com" -To "external-recipient@gmail.com" -Subject "Testing email relay using SMTP FQDN address" -Body "This is the body of email..." -SmtpServer "PRODMAIL02-VM.domain.com" -DeliveryNotificationOption OnFailure -Verbose

I can receive the email with no issue in the GMail mailbox.

So any help would be greatly appreciated.

Thanks,
0
Comment
7 Comments
 
LVL 27

Accepted Solution

by:
MAS earned 1000 total points
ID: 41720087
Do you have a internal to external NAT configured on firewall?
If not please configure and check. i.e. NLB IP to external.

I guess you will have to add the mac address of the NLB cluster.
1
 
LVL 8

Author Comment

by:Senior IT System Engineer
ID: 41720090
MAS, additional information:

I have added the IP address subnet of the server 10.1.1.0/24 in both HT/CAS External Receive Connector.

Cluster Operation is Multicast.
Cluster IP and Ports
Relay settings
Relay Settings 2
is that not enough ?
0
 
LVL 19

Assisted Solution

by:suriyaehnop
suriyaehnop earned 500 total points
ID: 41720114
Are you able to telnet smtp.domain.com 25? Do you able to see the banner
If you use OWA instead if powershell to send out email, does the email send out?
If you want to send an email to external using powrshell, you have to customized the receive connector

http://exchangeserverpro.com/exchange-2013-configure-smtp-relay-connector/
1
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
LVL 8

Author Comment

by:Senior IT System Engineer
ID: 41720116
Suriya,

Yes, I am able to use the OWA from outside of the office regularly. No issue using OWA.

My Exchange server is 2010 so the article is too new for me :-)

just that this new ERP system cannot send email using the SMTP.domain.com to external email address ?

But for internal email address from the copier, I can receive it to my internal mailbox.
0
 
LVL 19

Assisted Solution

by:suriyaehnop
suriyaehnop earned 500 total points
ID: 41720120
Yes, internal shall work. For external you have to modify the receive connector permission.

You may create a new connector and assign the correct permission, please refer to my url posted earlier
1
 
LVL 8

Author Comment

by:Senior IT System Engineer
ID: 41720144
Suriya, Does it means I need to create External relay (another Receive Connector) ?
because I rather not nodify the existing ones to avoid production issues.
0
 
LVL 30

Assisted Solution

by:Sudeep Sharma
Sudeep Sharma earned 500 total points
ID: 41723344
Hi ITSystemEngineer,

Are you sending the email through some other computer?

Connecting to your Edge server using telnet from the system which is not you CAS? Then what you are getting is fine. Except for the CAS server no other server should be able to relay the emails from your edge server. This is to stop the spam generating from the internal network due to some virus infection.

Thanks
Sudeep
1

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If something goes wrong with Exchange, your IT resources are in trouble.All Exchange server migration processes are not designed to be identical and though migrating email from on-premises Exchange mailbox to Cloud’s Office 365 is relatively simple…
Steps to fix “Unable to mount database. (hr=0x80004005, ec=1108)”.
This video shows how to use Hyena, from SystemTools Software, to update 100 user accounts from an external text file. View in 1080p for best video quality.
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
Suggested Courses

886 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question