Solved

Mailbox unavailable. The server response was: 5.7.1 Unable to relay - Sending email to Exchange HT/CAS behind Windows NLB

Posted on 2016-07-19
7
268 Views
Last Modified: 2016-08-04
Hi All,

I'm having problem with my server sending email out to external recipient.

Here's my details of Exchange 2010 VMs:

smtp.domain.com - 10.1.1.89 [WIndows NLB for load balancing the HT&CAS servers]
PRODMAIL01-VM - 10.1.1.90 [Hub Transport & Client Access Server]
PRODMAIL02-VM - 10.1.1.91  [Hub Transport & Client Access Server]

When I execute the below Powershell code from the server, the results are varying:


Send-MailMessage -From "sender@server.domain.com" -To "external-recipient@gmail.com" -Subject "Testing email relay using SMTP FQDN address" -Body "This is the body of email..." -SmtpServer "smtp.domain.com" -DeliveryNotificationOption OnFailure -Verbose

Result: Send-MailMessage : Mailbox unavailable. The server response was: 5.7.1 Unable to relay

But when I modify tthe SMTP server to use the HT/CAS server name, all is good:

Send-MailMessage -From "sender@server.domain.com" -To "external-recipient@gmail.com" -Subject "Testing email relay using SMTP FQDN address" -Body "This is the body of email..." -SmtpServer "PRODMAIL01-VM.domain.com" -DeliveryNotificationOption OnFailure -Verbose
and
Send-MailMessage -From "sender@server.domain.com" -To "external-recipient@gmail.com" -Subject "Testing email relay using SMTP FQDN address" -Body "This is the body of email..." -SmtpServer "PRODMAIL02-VM.domain.com" -DeliveryNotificationOption OnFailure -Verbose

I can receive the email with no issue in the GMail mailbox.

So any help would be greatly appreciated.

Thanks,
0
Comment
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 27

Accepted Solution

by:
☠MAS☠ earned 250 total points
ID: 41720087
Do you have a internal to external NAT configured on firewall?
If not please configure and check. i.e. NLB IP to external.

I guess you will have to add the mac address of the NLB cluster.
1
 
LVL 8

Author Comment

by:Senior IT System Engineer
ID: 41720090
MAS, additional information:

I have added the IP address subnet of the server 10.1.1.0/24 in both HT/CAS External Receive Connector.

Cluster Operation is Multicast.
Cluster IP and Ports
Relay settings
Relay Settings 2
is that not enough ?
0
 
LVL 19

Assisted Solution

by:suriyaehnop
suriyaehnop earned 125 total points
ID: 41720114
Are you able to telnet smtp.domain.com 25? Do you able to see the banner
If you use OWA instead if powershell to send out email, does the email send out?
If you want to send an email to external using powrshell, you have to customized the receive connector

http://exchangeserverpro.com/exchange-2013-configure-smtp-relay-connector/
1
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 8

Author Comment

by:Senior IT System Engineer
ID: 41720116
Suriya,

Yes, I am able to use the OWA from outside of the office regularly. No issue using OWA.

My Exchange server is 2010 so the article is too new for me :-)

just that this new ERP system cannot send email using the SMTP.domain.com to external email address ?

But for internal email address from the copier, I can receive it to my internal mailbox.
0
 
LVL 19

Assisted Solution

by:suriyaehnop
suriyaehnop earned 125 total points
ID: 41720120
Yes, internal shall work. For external you have to modify the receive connector permission.

You may create a new connector and assign the correct permission, please refer to my url posted earlier
1
 
LVL 8

Author Comment

by:Senior IT System Engineer
ID: 41720144
Suriya, Does it means I need to create External relay (another Receive Connector) ?
because I rather not nodify the existing ones to avoid production issues.
0
 
LVL 30

Assisted Solution

by:Sudeep Sharma
Sudeep Sharma earned 125 total points
ID: 41723344
Hi ITSystemEngineer,

Are you sending the email through some other computer?

Connecting to your Edge server using telnet from the system which is not you CAS? Then what you are getting is fine. Except for the CAS server no other server should be able to relay the emails from your edge server. This is to stop the spam generating from the internal network due to some virus infection.

Thanks
Sudeep
1

Featured Post

Database Solutions Engineer FAQs

In this series, we will discuss common questions received as a database Solutions Engineer at Percona. In this role, we speak with a wide array of MySQL and MongoDB users responsible for both extremely large and complex environments to smaller single-server environments.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For anyone that has accidentally used newSID with Server 2008 R2 (like I did) and hasn't been able to get the server running again because you were unlucky (as I was) and had no backups - I was able to get things working by doing a Registry Hive rec…
Here's a look at newsworthy articles and community happenings during the last month.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video discusses moving either the default database or any database to a new volume.
Suggested Courses

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question