?
Solved

Exchange Performance Query related to TLS upgrade

Posted on 2016-07-19
6
Medium Priority
?
160 Views
Last Modified: 2016-07-24
Heyas,

We are running Mcafee SAAS to secure our exchange 2010 communications. Recently we switched from TLS 1.0 to TLS 1.2 and ever since then several of our applications which do batch mailouts of reports have been taking a long time to email.

As far as know no other changes have occurred in the network.

How would I go about troubleshooting this from the exchange end?

Any assistance is appreciated.

Thank you
0
Comment
Question by:Zack
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 33

Expert Comment

by:Busbar
ID: 41720279
Do they send using SMTP ?! did you configure SMTP to use SSL !?
0
 

Author Comment

by:Zack
ID: 41720285
Hi Mahmound,

Yes, it sends using the SMTP and SSL used as well.

Thank you.
0
 
LVL 33

Expert Comment

by:Busbar
ID: 41720290
would this be causes because you lack this update https://support.microsoft.com/en-us/kb/3029667
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 

Author Comment

by:Zack
ID: 41720989
Hi Bushbar,

My apologies for not getting back to your sooner. Thank you for the update link I will check. A query how would this cause performance issues?

Thank you.
0
 
LVL 33

Accepted Solution

by:
Busbar earned 2000 total points
ID: 41721021
I think, and I might be wrong, that apps are trying to connect using TLS1.2, timesout then fails back to 1.0 or something like this, wireshark sniffing will help for sure.
0
 

Author Closing Comment

by:Zack
ID: 41726849
Hi Busbar,

Finally worked it out via wireshark it was an issue with TLS timeout but it was only occurring on one of the relay servers.

Thank you.
0

Featured Post

Ransomware Attacks Keeping You Up at Night?

Will your organization be ransomware's next victim?  The good news is that these attacks are predicable and therefore preventable. Learn more about how you can  stop a ransomware attacks before encryption takes place with our Ransomware Prevention Kit!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
This article is written by John Gates, CISSP. Gates, the SNUG President-Elect, currently holds the position of Manager of Information Systems at Lake Park High School in Roselle, Illinois.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question