[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Outlook 2016, Exchange 2016, When i close Outlook you have to wait 20 min before you can open it again.

Posted on 2016-07-20
15
Medium Priority
?
207 Views
Last Modified: 2016-07-22
Hi,

I'm having the following issue with clients since we've started upgrading to exchange 2016 and outlook 2016.
This is whats happening. everything is working fine and for some reason you close down outlook, when you start it again you will get the attached error.

 "Cannot start microsoft outlook. Cannot open the outlook window. the set of folders cannot be opened. microsoft exchange is not available. either there are network problems or the exchange server is down for maintenance.

When you wait 20 to 25 min you can start it up fine again.

I came across a microsoft workaround that tells you to recycle the autodiscoverpool in your iis every few minutes. i'v set this up but besides creating a whole different list of errors and problems this does not seem to resolve the above issue.

I'v updated the clients and updated the exchange server 2016 to CU2.

Any idea's would be most welcome at this point.

Thanks alot
Martijn Boevé
OutlookError.PNG
0
Comment
Question by:tinus67
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 6
15 Comments
 
LVL 11

Expert Comment

by:Old User
ID: 41720869
0
 

Author Comment

by:tinus67
ID: 41720886
Hi Dave,

Thanks but just tried this and doesn't seem to work.

Martijn Boevé
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 41721392
Not something I have seen myself.
The usual of something like that though is third party interference. AV software scanning something it shouldn't be, or a plugin within Outlook.

Go through the server's application logs for anything suspicious. If AV is installed on the server, ensure it has the correct exclusions in it.
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 

Author Comment

by:tinus67
ID: 41722309
Hi Simon,

We Checked the plugins and tested it without any plugins, no changes.
also we uninstalled the AV software completely but no difference there either.

The problem has spread though, got 3 other customers with the same issue, and our own server is having this problem also now.

All recently installed Echange 2016 servers.
Thats the one thing i'm absolutely sure about, its all connected to that exchange 2016 server.

We are now testing with the RPC session timeout settings and MAPI settings, hoping that will do something.

will keep you posted.

Martijn Boevé
0
 

Author Comment

by:tinus67
ID: 41722811
Little Update:

When someone is locked out of there outlook and we run a IISRESET on the exchange server there able to get back in again.
when they close outlook again after that the problem is right back though.

but look like IISRESET does seem to somehow reset the timer.
Can't really schedule this to reset every few minutes though as this disconnects everyone's outlook as well.

Martijn Boeve
0
 

Author Comment

by:tinus67
ID: 41722833
Another Update:

We just disabled MAPI connections on a PC trough a regkey setting. (So we are forcing the workstation to connect to the exchange server via RPC)

What do you know, it works. when forced to connect over RPC there are no problems. (Not a long term solution though as the RPC connections are noticeably slower then the MAPI connections.
Ok, so now we know are the problem lies. its the MAPI connector on the exchange server side thats messing up.

How to fix this.?.?

Will keep you posted.


Martijn Boevé
0
 
LVL 11

Expert Comment

by:Old User
ID: 41722835
Hi Martin,

Can you check the connect status on one of the accounts that has this issue. I am interested in the Protocol.

to do this hold down CTRL key and right click on the Outlook icon in the system tray then click connection status.
0
 

Author Comment

by:tinus67
ID: 41722840
Hi Dave,

Here are 2 screenshots, one from a computer without registry alteration so going over MAPI, and one with the RPC connection forced trough Registry fix.

MAPI ConnectionRPC Connection

Martijn Boevé
0
 
LVL 11

Expert Comment

by:Old User
ID: 41722846
Okay, can you open Exchange powershell and run this

Get-OrganizationConfig | fl *mapi*
0
 
LVL 11

Expert Comment

by:Old User
ID: 41722856
This will tell us if mapi is enabled, i don't think it is by default.

When it is enabled this should force all Outlook clients to connect using mapi over http.
Any Outlook clients that are running will be prompted to restart Outlook
0
 

Author Comment

by:tinus67
ID: 41722938
Hi Dave,

The command gave back that the Mapi is enabled. But we still have the isues when you close a outlook. Domain pc or non domain pc. Cached mode on or off doesn't matter.
When we close it it takes ~20min before the person can reopen outlook unless i do a issreset.
0
 
LVL 11

Accepted Solution

by:
Old User earned 2000 total points
ID: 41723738
As you have stated that you think the issue is mapi I would suggest disabling mapi therefore forcing all outlook clients over rpc

Run this in Exchange power she'll

Set-OrganizationConfig -MapiHttpEnabled $false
0
 

Author Comment

by:tinus67
ID: 41724122
Hi Dave,

This seems to work, what is does i imagine is the same as my reg fix only it sets it for the who server at once, nice.

Were testing it this morning at 1 over the customers. Will update and or close the case as soon as i know someting.

Cheers.
0
 
LVL 11

Expert Comment

by:Old User
ID: 41724129
It does, as you say the same thing but without needing to modify the registry on every client
0
 

Author Comment

by:tinus67
ID: 41724170
Just a small update:
I have disabled the mapi and so far all the issues are gone. For people reading this later.
run a iisreset.
run the command.
(then ran another 1 just to be safe and make sure everyone has fresh connections)
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If something goes wrong with Exchange, your IT resources are in trouble.All Exchange server migration processes are not designed to be identical and though migrating email from on-premises Exchange mailbox to Cloud’s Office 365 is relatively simple…
This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question