How do I fix "You do not have access rights" when accessing Disk Management on remote computer in a Workgroup

Windows admins will be familiar with Computer Management, An awesome saved window for MMC. I'm getting Access Denied when I try to access Device Manager and "You do not have access rights to logical disk manager"  I have created a reciprocal admin user on the remote machine (matching the local username and password exactly) and that allows me to access the services snap-in and others.

These computer are NOT on a domain, nor is that an option.

I have tried disabling UAC on remote computer
turning off firewall on both local and remote computers
recreating remote admin account on local computer and using that
Made sure that Remote Registry and Plug and Play services were running on the remote machine

All systems running Windows 10 Pro. Disk Management works fine when run from the local machine.
TrystenProgrammerAsked:
Who is Participating?
 
McKnifeCommented:
Ok, I tried it here.
Even with the firewall completely open, with plug and play service and remote registry service running on the remote machine, I cannot access device manager nor disk management from remote. This is NOT supposed to work anymore, I guess.
I can still access the services snapin from remote and several others like task scheduler.
1
 
JohnBusiness Consultant (Owner)Commented:
Are you the computer administrator?  Can you log on with an admin ID?

Is this Windows Home?
0
 
TrystenProgrammerAuthor Commented:
As the body of my question implies, yes both local and remote accounts are in the Administrators group. I am able to login to the remote computer with the account created. All systems running Windows 10 Pro. Damnit John.
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
JohnBusiness Consultant (Owner)Commented:
I missed the last line - sorry. Something has gone wrong with Windows 10.

1. Run SFC /SCANNOW from an admin command prompt. Restart and test.
2. No? Run DISM.

Open cmd.exe with Run as Administrator.
DISM.exe /Online /Cleanup-Image /Scanhealth (takes 15 - 20 minutes).
DISM.exe /Online /Cleanup-Image /Restorehealth (takes 15 - 20 minutes).
Restart the computer and test.
1
 
TrystenProgrammerAuthor Commented:
Thanks John. Sorry for my earlier snarkiness. SFC Fails. DISM /Scanhealth succeeds but /Restorehealth fails. My Windows 10 installation media doesn't have an install.wim that I can find. It does have install.esd though

C:\WINDOWS\system32>DISM.exe /Online /Cleanup-Image /Scanhealth

Deployment Image Servicing and Management tool
Version: 10.0.10586.0

Image Version: 10.0.10586.0

[==========================100.0%==========================]
The component store is repairable.
The operation completed successfully.

C:\WINDOWS\system32>DISM.exe /Online /Cleanup-Image /Restorehealth

Deployment Image Servicing and Management tool
Version: 10.0.10586.0

Image Version: 10.0.10586.0

[==========================100.0%==========================]

Error: 0x800f081f

The source files could not be found.
Use the "Source" option to specify the location of the files that are required to restore the feature. For more information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077.

The DISM log file can be found at C:\WINDOWS\Logs\DISM\dism.log
0
 
JohnBusiness Consultant (Owner)Commented:
Sorry for my earlier oversight but I am trying to help you. When DISM fails, it is because of the version of Windows 10 you are now on compared to when the image on the disk was set up.

If DISM will not run (mismatch) go to Microsoft Tech Bench and download the 64-bit English ISO
Burn the ISO to a DVD so as to see all the files including install.wim

First mount the file as follows:
DISM.exe /Mount-Wim /WimFile:C:\test\images\myimage.wim /index:1  /MountDir:C:\test\offline

Then run the DISM command
0
 
awawadaCommented:
I have seen this problem on infected clients. Was this Windows 10 client infected?
0
 
JohnBusiness Consultant (Owner)Commented:
I have gotten the error number above myself. DISM does not keep up with Windows Updates.

@rdjones316 - If getting DISM to work is a bit daunting (it is daunting), you can do an in-place Windows 10 repair without losing anything.  Go to the Media Creation Link:

https://www.microsoft.com/en-us/software-download/windows10

Click on Upgrade to Windows 10 (even though you are running Windows 10), allow drivers to update, then click on Keep Data and Keep Applications. Everything will be retained. I have done this.
1
 
McKnifeCommented:
I bet this is not due to corruption or virii.
Remote device manager is no longer possible in windows. Blocked by default. Remote diskmanagement requires certain firewall rules. If the fw is off, it does not necessarily mean it has to work.

I will retry with clean machines in the office on Monday, if you like.
0
 
TrystenProgrammerAuthor Commented:
Damn. That's disappointing. Maybe it's disabled by default and just needs some (group) policy changes to get it to work. I think I remember seeing a policy about Disk Management when browsing for solutions. I can access services also. I will keep working on this.
0
 
McKnifeCommented:
Remote device manager used to work but was disabled starting with win8 - this was even documented by Microsoft. I guess for some security reason, they disabled remote disk management , too. No, there's no GPO for this.
0
 
TrystenProgrammerAuthor Commented:
But not really because I can still psexec \\remote diskpart

silly microsoft..
0
 
McKnifeCommented:
Psexec works differently.
0
 
TrystenProgrammerAuthor Commented:
No solution. Apparently Microsoft has disabled this function.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.