Solved

Linux : adding the new user with password option,

Posted on 2016-07-25
11
124 Views
Last Modified: 2016-07-26
i have created user with password option

#useradd -p user01 user01

When I tried to login with user01, am getting below error message, despite having correct password.

--
[user01@SRV1 ~]$ su - user01
Password:
su: incorrect password
--

I want to  give password option in Single command.

please advice how to achieve the same
0
Comment
Question by:mac_g
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +2
11 Comments
 
LVL 30

Expert Comment

by:Sudeep Sharma
ID: 41727887
In your question it seems that you are already logged in with user "user01"

[user01@SRV1 ~]$ su - user01

Log off and try to su - user01 again and check.

Sudeep
0
 
LVL 7

Expert Comment

by:David Sankovsky
ID: 41727889
As far as I know there isn't a way to do so. Also it's very insecure!!!!
The password should be typed, to make sure that only the person who should have the required access. gets it.
Also, Don't open a new ticket on every question you have... I've 3 questions that you've opened today that relate to the same thing.
Please choose a solution for the question you left open and close them.
0
 

Author Comment

by:mac_g
ID: 41727892
thanks David.As it is urgent no option but to raise the new question.
0
Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

 
LVL 7

Expert Comment

by:David Sankovsky
ID: 41727898
People who answered you previous questions are notified when you post something new..
0
 

Author Comment

by:mac_g
ID: 41727901
this activity has to perform on lot of users.
I want to simply the process by using single command.

@david, I agree it is insure

@sudeep, the output captured to show the error message while login, despite I give -p option in "useradd" command.
0
 
LVL 7

Expert Comment

by:David Sankovsky
ID: 41727905
OHH you want to create a user and pass the password as a parameter?
try
useradd -p<password> username

Open in new window

There should be no space between the -p flag and the password
0
 

Author Comment

by:mac_g
ID: 41727920
#useradd -p test02 test02

su - test02
Password:
su: incorrect password

==
when I am giving -p option as command line it is not working.
I tried multiple time ....

any way to fix this ?
0
 
LVL 30

Expert Comment

by:Sudeep Sharma
ID: 41727985
there should be no gap between -p and your password.

The command should be:
useradd -ptest02 test02
0
 

Author Comment

by:mac_g
ID: 41728002
==
[root@SRV ~]# useradd -paa aa
[root@SRV ~]# su - aa
[aa@SRV ~]$ su - aa
Password:
su: incorrect password
==
0
 
LVL 29

Accepted Solution

by:
serialband earned 500 total points
ID: 41728595
You can't add a plain text password that way.  You're supposed to use the encrypted password hash. (what you would find in /etc/shadow).

useradd -p<user1_encrypted_hash> user01


You can use openssl to generate the password with a salt.
openssl passwd -1 -salt abc user01
$1$abc$ajQu7bKl0KZgRhWbXLR6g1

You use the salted hash as your password.
useradd -p$1$abc$ajQu7bKl0KZgRhWbXLR6g1  user01

You could technically combine then.  (Please note:  Use the backquote found under the tilde (~) symbol near the top left on a US keyboard layout.)
useradd -p`openssl passwd -1 -salt abc user01`  user01

This should only ever be done on a secure system that isn't accessible to all users, as they can watch the process table and grab every one of your passwords.  You should clear your history file (history -c in bash).  You should also force users to change their password and make this a one time, initial password only.

Generally, you should create the passwords separately.
0
 
LVL 3

Expert Comment

by:Kevin Pham
ID: 41730141
Correct Syntax: useradd -p encrypted_password username

You cannot specify a plaint-text password and expect it to work. The password as you specify (if you view /etc/shadow) will be recorded exactly as it was typed.

You can do something like this as one line
useradd -p $(openssl passwd -1 <password>) <username>
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Why Shell Scripting? Shell scripting is a powerful method of accessing UNIX systems and it is very flexible. Shell scripts are required when we want to execute a sequence of commands in Unix flavored operating systems. “Shell” is the command line i…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question