Audio player won't start songs automatically on my Android phone

I have a series of each of which has its own page with code that should make the song start playing automatically but it doesn't. Here's the code I'm using, what can I add or modify that will make the song start playing on load or perhaps within 2 seconds.
<audio src="Songs/Man Of My Words.mp3" controls>    
	<embed 
	src="Songs/Man Of My Words.mp3"
	width="360"
	height="90"
	loop="false"
	autostart="true" />   
</audio>

Open in new window


Thanks!
John
LVL 1
John CarneyReliability Business Tools Analyst IIAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Justin SmithWriterCommented:
http://www.thesitewizard.com/webdesign/backgroundmusic.shtml

This might help a little.

Or try this code:

try this html5 code.....

 <html>
<body>

<audio controls autoplay>
  <source src="zui you ji.mp3" type="audio/mpeg">
</audio>

</body>
</html>
0
Jackie ManCommented:
Which browser you are using?

Autoplay on load is blocked by the browser by default.

If you are using Chrome on Android, you need to change the settings.

1. type chrome://flags and press enter in URL

2. Find "Disable gesture requirement for media playback" and enable this setting

Source: http://stackoverflow.com/questions/12587977/html5-audio-chrome-on-android-doesnt-automatically-play-song-vs-chrome-on-pc-d
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
John CarneyReliability Business Tools Analyst IIAuthor Commented:
Hi Jackie, thanks.  I couldn't find it at first because I was looking for the words "Disable gesture requirement for media playback." On a second scroll, I happened to notice "gesture requirement for media playback," which was enabled and all I had to do was disable it. And that did it!

Thanks again, John
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Android

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.