• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 156
  • Last Modified:


I already see 1 cpu and 4gb ram installed but is greyed out.

I was told to do below

I have  to add 1 cpu and 4gb additional ram to windows server 2008R2 which is on VMware 5.5
right now both cpu and memory are greyed out because looks to me I don’t have Hot-Add/Hot-Plug capabilities

1 Solution
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
If you have not enabled Hot Plug CPU and Memory on the VM, which you need to do, before you use those options, they are not enabled by default.

OR you do not have a license for Hot Plug CPU and Memory.

You will NEED to Power OFF the VM, Right Click the VM Edit Settings, and change the CPU and Memory.

Also remember not all Operating Systems support Hot Plug CPU and Memory.

Also see here

CPU Hot Plug Enable and Disable options are grayed out for virtual machines (2020993)


Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Tackle projects and never again get stuck behind a technical roadblock.
Join Now