Exchange Management Console Error - Initialization falied

when i open my EMC CONSOLE i am getting the error as attached in the pic. Restarted the server too.. still getting the same error.

let me know as how to resolve this error.

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

FOXActive Directory/Exchange EngineerCommented:
Verify if your world wide web publishing service is on.  If not turn it on.  Also ref the below link

ref link:
o0JoeCool0oAuthor Commented:
world wide service is running . restarted it too. did not work.

wanted to try the method as given in the link

Method 1:

Close all MMC/EMC instances before proceeding.
Open Registry Editor (regedit) as the user you run the EMC under.
Go to HKEY_CURRENT_USER\SOFTWARE\Microsoft\ExchangeServer\v14\AdminTools
Look for value NodeStructureSetting.
If it is there, back it up and then remove it.

How to backup the above? i am confused as how to do this step.
FOXActive Directory/Exchange EngineerCommented:
Once you navigate to NodeStructureSetting, highlight it then hit file>export and save the .reg file with a name of your liking to a location you save it to.  It saves the registry key with it's tree location in case you need to import it back in.
SolarWinds® VoIP and Network Quality Manager(VNQM)

WAN and VoIP monitoring tools that can help with troubleshooting via an intuitive web interface. Review quality of service data, including jitter, latency, packet loss, and MOS. Troubleshoot call performance and correlate call issues with WAN performance for Cisco and Avaya calls

o0JoeCool0oAuthor Commented:
thanks got the EMC working again.

when i open the database of the public folder in EMC. i am getting this error. the pic is attached

any ideas?
FOXActive Directory/Exchange EngineerCommented:
Can you ping the server in that error.  Also go in to services on the server it mentioned and make sure the information store service is started
o0JoeCool0oAuthor Commented:
yes i can ping the server in the error and also made sure that the information store service is started on the other server too
o0JoeCool0oAuthor Commented:
in my EMC console under microsoft exchange on -permises it is showing the wrong server.

when i choose the right server to connect to.. it is giving me the error as in the picture.

tried this method : it only helped me to opne the EMC but not connect to the correct server.

Any ideas?

Method 1:

Close all MMC/EMC instances before proceeding.
Open Registry Editor (regedit) as the user you run the EMC under.
Go to HKEY_CURRENT_USER\SOFTWARE\Microsoft\ExchangeServer\v14\AdminTools
Look for value NodeStructureSetting.
If it is there, back it up and then remove it.
Britt ThompsonSr. Systems EngineerCommented:
If you disabled ipv6 on the exchange box re-enable it. Also, make sure the server is resolving it's fqdn correctly.
o0JoeCool0oAuthor Commented:
ipv6 is already enabled on the server.
how to make sure that the server is resolving its fqdn correctly.
Britt ThompsonSr. Systems EngineerCommented:
The name resolution check can be done by simply running a ping in the command line to the server's short name - i.e., ping EXCHANGE01 - if it resolves the correct IP then that name is good. So, try pinging the full server name - i.e., ping

You may also see this problem if you have removed the built-in self-signed certificate (which would need to be regenerated and replaced) or, if you're unable to see a Global Catalog server in the domain. Typically, your GC is your domain controller. Ensure you're  using the IP address of your domain DNS server, typically you domain controller, as the first IP in your DNS list - do not use any DNS server other than your domain integrated DNS servers.
Mohammed HamadaSenior IT ConsultantCommented:
Try to check if the features WCF and HTTP Activation are enabled on Exchange Server

If they are enabled then download and try using EMTshooter.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
o0JoeCool0oAuthor Commented:
the name resolution worked fine. no issue with that. ip address of your dns server is all good.

how and where to check if the feature wcf and http activation are enabled on the exchange server?

when i opened the powershell. it started to connect the right server... then it gave a error and connected to the wrong server and when i tried to browse the directory where the emt shooter file.. it could not find out?
o0JoeCool0oAuthor Commented:
this is the error when i try to connect the EMC to the right server

Unable to open Exchange Server 2010’s Exchange Management Console with the error: “The attempt to connect to using "Kerberos" authentication failed: Connecting to remote server failed...”

the pic is attached for your reference
Mohammed HamadaSenior IT ConsultantCommented:
Just to double check that you have all Prerequesties installed. using the following script

From Powershell on the problematic Exchange server

Import-Module Servermanager 

Add-WindowsFeature Desktop-Experience,NET-Framework,RSAT-ADDS,Web-Server,Web-Basic-Auth,Web-Windows-Auth,Web-Metabase,Web-Net-Ext,Web-Lgcy-Mgmt-Console,WAS-Process-Model,RSAT-Web-Server,Web-ISAPI-Ext,Web-Digest-Auth,Web-Dyn-Compression,NET-HTTP-Activation,RPC-Over-HTTP-Proxy -Restart

Open in new window

The EMTshooter doesn't work because you're trying to browse it from the other Exchange server. I am assuming that you copied the EMTShooter to the problematic server where Exchange Management shell is failing to connect. then it connects to the other exchange server where EMTshooter doesn't exist there.

If you want to troubleshoot with EMTshooter, you need to run it from normal Powershell not EMC ..
o0JoeCool0oAuthor Commented:
yes you are right i am trying tO run the emtshooter from the problematic server.

the above solution did not help me out.

the steps of error are given below just to clarify:

step 1: when i open the emc console.. i see the wrong server there.  It shows the CAS SERVER .. not the server name on which the EMC is opened (picture 1)

step 2: when i right clink on it and click on properties and browse to the correct server (picture 2)

step 3: i get this error. (picture 3).

i want the emc to show the right server.

please note that we have 3 exchange server that acts as CAS.
Mohammed HamadaSenior IT ConsultantCommented:
It won't connect because apparently your server has an issue .. that's why I asked you to run EMTshooter .. it'll check your IIS and see if it has any issues ..

Try to launch Powershell on the problematic Server with administrative privilidges .. then navigate to the location of the EMTshooter after you have renamed the EMTshooter's extension to .ps1 then launch it and post the result here.

also in the problematic server open Event viewer from run --> eventvwr
in the Application tab filter the critical, errors and warnings and post the last 20 events here.
o0JoeCool0oAuthor Commented:
Thank you EMT shooter fixed the issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.