• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 72
  • Last Modified:

Exchange 2010 "Send on Behalf of" doesn't work

hello, I am running Exchange 2010 and client is Outlook 2013. I have a shared mailbox which is used by department users to reply on behalf of Sales. I have granted "Manage Full Access Permission" to these users and also added them "Send on Behalf of" in the Delivery options. Still when they use this email account in the "From" field to send out a reply, they get a NDR stating they do not have permission to send on behalf of this user. Strange thing is it always works the first time they send an email using the "from", but fails everytime afterwards. Another strange thing thing is that if they select "other email address" and select Sales from the address list, the mail is delivered without any issue.
Is there something I am missing or doing wrong.
0
Antonio02
Asked:
Antonio02
  • 5
  • 2
4 Solutions
 
Nick RhodeIT DirectorCommented:
This should help to make sure the permissions are setup correctly.

Mailbox Access Rights

Setup by step guide and walkthrough with detailed explanations on Full Access/Send On Behalf/Send As permissions for users.  I am just assuming you are missing one small step
0
 
Antonio02Author Commented:
Thanks Nick, I have granted myself "Manage Full Access" and "Manage Send As" permissions. I have also added myself to "Send on Behalf of" and still continue to get the NDR saying I do not have the permission to send on behalf of this user. Strange thing is that if from the "From" drop down box, instead of selecting the Sales.xyz.com, I select other user, and select sales.xyz.com, I have no issue sending the mail.
0
 
Tej Pratap Shukla ~DexterServer AdministratorCommented:
HI,
You should visit below links to fix  "Send on Behalf does not work" issue:
https://social.technet.microsoft.com/Forums/exchange/en-US/71cc6355-1bd9-4114-bd21-bce954d006c4/send-as-send-on-behalf-not-working-with-exchange-2013?forum=exchangesvrsharingcollab
https://blogs.technet.microsoft.com/ehlro/2012/04/06/full-mailbox-access-rights-send-on-behalf-send-as/
https://social.technet.microsoft.com/Forums/exchange/en-US/30e946c9-5b15-403f-9ee6-3bcaa2857909/send-as-permissions-not-working-still-says-send-on-behalf-of?forum=exchange2010

You can also try running below given command to assign full access permission:
Add-MailboxPermission -Identity abcdef -User username -AccessRights FullAccess -InheritanceType All

Open in new window

0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Nick RhodeIT DirectorCommented:
Was this group recreated at one point?  I have seen an issue like that were something is recreated and the cached address points to the mailbox/group that was removed and readded.  You would get an NDR because the cached address is resolving to a deleted mailbox/distribution group.
0
 
Antonio02Author Commented:
Hi Nick,

That is what I was looking into also, however I cannot find a record of this email account being deleted or readded. The strange part is that this shared account is used by over 30 sales reps to reply back to sales inquiries, however a handful of sales people get a NDR when replying. If instead of selcting the email adddress from the dropdown list, they select "other user" and select this email address from the GAL, they can send the email successfully. Its only when they select this address from the "From" dropdown is they get a NDR. They are also getting an NDR when they select other user and manually type the sales@xyz.com.
0
 
Antonio02Author Commented:
Thanks Tej, I have checked these links and nothing seems to help at this point.
0
 
Antonio02Author Commented:
Ok, so I figured out the issue was with the Global Address List. I download the GAL and once done users are able to "send on behalf of" without any issues. Thanks so much for the advise and help.
0
 
Antonio02Author Commented:
Ok, so I figured out the issue was with the Global Address List. I download the GAL and once done users are able to "send on behalf of" without any issues. Thanks so much for the advise and help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now