Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Windows server backup failing - volume shadow copy issue

Posted on 2016-07-27
7
Medium Priority
?
997 Views
Last Modified: 2016-10-31
Greetings,

I have a Windows Server 2011 Small Business and I have developed an issue in which the backup is failing every time.

Due to the error messages i believe this is related to Volume Shadow Copy.  One reason i think this is because I use another software called Cobian for copying files and it reports errors aboutr Volume shadow copy.  

I have recently changed the administrator password for this server.  I'm not sure if that is related.  I had a ransomware issue on this network and I have not been able to use windows server backup successfully. Right now I am cancelling a backup job that started yesterday at 6 pm.

Any recommendations on where to start on troubleshooting this will be greatly appreciated.

Thank you.

Sky
0
Comment
Question by:Schuyler Kuhl
  • 3
5 Comments
 
LVL 18

Expert Comment

by:Wayne88
ID: 41731895
Is the backup failing because it failed to run or the backup itself is no good (corrupted)?  Did you restart the server after changing the administrator's password?

Can you go to services.msc then ensure the Windows Backup and Volume Shardow Copy services are running?  If not then try starting it up.  If it doesn't start then go to the Event Viewer and see why it failed.  Perhaps try changing the logon credentials to administrator with the new password then try starting the services again.  To be safe, restart the server after after making the change to see if it helps.
0
 
LVL 47

Expert Comment

by:noxcho
ID: 41732467
What kind of errors are you getting? Can post the error message here?
0
 

Author Comment

by:Schuyler Kuhl
ID: 41738888
Hello,

Really sorry about the delay on this.

The Volume Shadow Copy service is running but I could not find a windows backup or windows server backup service.

I am not a master at reading the logs but there are errors for Sharepoint Foundation and Sharepoint Foundation Search.  I can't find specific errors on the backup.  

regarding the sharepoint errors, some of what I have read relates this service to backup issues.  When I look into this in services I see that there is a user spfarm that I am not familiar with.

The error in the Server Backup tool is:

the volume shadow copy operation failed with error 0x800423f3

The backup error in the application log is this:
The backup operation that started at '‎2016‎-‎08‎-‎01T22:00:11.021000000Z' has failed because the Volume Shadow Copy Service operation to create a shadow copy of the volumes being backed up failed with following error code '2155348129'. Please review the event details for a solution, and then rerun the backup operation once the issue is resolved.

In the application log this morning I see this vss error:  

VssAdmin: Unable to create a shadow copy: Another shadow-copy creation is in progress, so the current shadow copy cannot be created.  There are a number of common scenarios causing this problem:          * If Shadow Copies of Shared Folders is set up, ensure that no two volumes have schedules that lie within five minutes             of each other.           * If automatic backup of any form is scheduled, ensure that the backup schedule does not overlap with the schedule            used for Shadow Copies of Shared Folders.    Generally, retrying the operation after a few minutes or changing the schedule of an automatic task should fix this problem.
Command-line: 'C:\Windows\system32\vssadmin.exe Create Shadow /AutoRetry=15 /For=C:\'.

This one also I believe is related to the sharepoint errors:

Volume Shadow Copy Service error: Failed resolving account spsearch with status 1376. Check connection to domain controller and VssAccessControl registry key.

I keep coming back to this in my research on this issue: Sharepoint Foundation is causing the issue. By running the "Sharepoint 2010 Products Configuration Wizard", it will fix the backup issue.

I am not familiar with that and I haven't done it but the fact that there are many sharepoint errors in the logs makes me think it may be related.

Sorry to be so scattered with my thinking here.  Any recommendations you can provide are greatly appreciated.  Thank you.
0
 
LVL 47

Expert Comment

by:noxcho
ID: 41738965
0
 
LVL 47

Accepted Solution

by:
noxcho earned 2000 total points
ID: 41865126
The link in my last comment should have helped to resolve the problem.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The main intent of this article is to make you aware of ‘Exchange fail to mount’ error, its effects, causes, and solution.
Here in this article, you will get a step by step guidance on how to restore an Exchange database to a recovery database. Get a brief on Recovery Database and how it can be used to restore Exchange database in this section!
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
Suggested Courses

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question