Solved

Sharepoint List, How can i remove an item from the list?

Posted on 2016-07-28
32
91 Views
Last Modified: 2016-07-29
I'm new to the SharePoint fiasco, I see there is a list with 22 records I need to remove one of those. I have gone to site setting and locate the list. open the list and click on the tittle bar and see where Items and List heading shows at the top. Under Items I see the edit item and Delete Item but they are gray out. What do I need to do, go, click in order to delete one item of the list?
0
Comment
Question by:COHFL
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 14
  • 10
  • 8
32 Comments
 
LVL 10

Expert Comment

by:Tim Edwards
ID: 41733774
Are you an owner or contributer to the site? if so they may have broken the permissions at the list level, go into the list settings and check the permissions there if you have access.

Are you taking over the SharePoint environment from another individual?
0
 

Author Comment

by:COHFL
ID: 41733804
I'm an owner of the list and yes I'm taking over from someone else. I think permissions are broken somewhere else =(
0
 
LVL 10

Expert Comment

by:Tim Edwards
ID: 41733840
This may be a dumb response, but when you go to the list and see the items greyed out on the top have you clicked on the record in question that you want to delete?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:COHFL
ID: 41733846
It is not a dumb response, it is totally valid. I can't click or select anything hence the edit option is unavailable. I guess it has to do with the fact that the item on a list take you to another page. I don't know if this helps
0
 
LVL 10

Expert Comment

by:Tim Edwards
ID: 41733915
Can you provide a screen shot and paint over any confidential information please
0
 

Author Comment

by:COHFL
ID: 41734617
This is the list and we need to remove the second item, the check box next to it cant be click or selectedCapture2.JPG
0
 

Author Comment

by:COHFL
ID: 41734623
Capture.JPG
0
 
LVL 10

Expert Comment

by:Tim Edwards
ID: 41734683
Thank you,

If you click on the List Tab, do you get the option to do a quick edit on the list, The image below shows with the navigation when selecting a single list item. We will have to a look further at the list permissions.

SharePoint.PNG
0
 

Author Comment

by:COHFL
ID: 41734696
Nope this is what I get:
Capture.JPG
0
 
LVL 10

Expert Comment

by:Tim Edwards
ID: 41734705
Okay lets take a look at the permission, from the list tab go into List Settings
SharePointListSettings.PNG
From there open the list permissions.
SharePointListPermissions.PNG
And lets verify that the inheritance has not been broken on th e list
SharePointBrokenPermissions.PNG
0
 

Author Comment

by:COHFL
ID: 41734707
this is what I have
Capture.JPG
0
 

Author Comment

by:COHFL
ID: 41734708
This group is part of an Active Directory group and I'm part of that group
0
 
LVL 10

Expert Comment

by:Tim Edwards
ID: 41734715
Try to granting the account that you are currently logged in with either edit rights or owner directly to the list.
0
 

Author Comment

by:COHFL
ID: 41734725
I add myself to the list with edit permissions and still doesn't work. I have add the Full Control and still can not do the quick edit =(
0
 
LVL 19

Expert Comment

by:Walter Curtis
ID: 41734891
Look at the screenshot from 7:53,  the item tab needs to be highlighted so that you can edit or delete items. This shows the list tab as highlighted.

Maybe something, maybe not...
0
 

Author Comment

by:COHFL
ID: 41735002
Items is not enable either
0
 
LVL 19

Expert Comment

by:Walter Curtis
ID: 41735017
Ok, good that you are in the right place..

A few points -

Above you mention that the SharePoint group is part of the AD group. The way it works is that an AD group can be a member of a SharePoint group, but not the other way around. So make sure you are in the AD group. One way to check is to use the "Check Permission" icon, in the ribbon, shown in your screenshot from 08:02. You will be able to check exactly what permission you have on the item.

You could also test by granting your account explicit access. From the same place shown above, click on "Grant Permissions" and add yourself.

Another test, add an item, then see if you can delete. Often, a custom permission is used that allows one to add items but not delete items. Maybe that is in play here.

Good luck...
0
 
LVL 10

Expert Comment

by:Tim Edwards
ID: 41735023
In the first image you should me you were in designer, please go back into designer. On the bottom were it shows content type click on  list, under the settings make sure that Allow modifications is checked off.
SharePoint.PNG
0
 
LVL 19

Expert Comment

by:Walter Curtis
ID: 41735027
Good thought, but be careful. Please don't modify content type settings. That has nothing to do with deleting list items.
0
 

Author Comment

by:COHFL
ID: 41735034
Here is the permission check screen for me (Im not Jdolphin just for illustration purposes_
Capture.JPG
0
 
LVL 10

Expert Comment

by:Tim Edwards
ID: 41735039
Go back to the Library Settings, this time open up the advanced setting.

Check the following - Item-Level Permissions for Create and Edit Access verify that it is set to Create and edit all items

Then scroll down and verify the at the quick edit is enabled.
0
 

Author Comment

by:COHFL
ID: 41735041
@Tim Edwards on this post 2016-07-29 at 07:49:04   ID: 41734623  I don't have the allow modifications.
I have Allow attachment, Allow management of content types that's it
0
 
LVL 19

Expert Comment

by:Walter Curtis
ID: 41735050
Don't do anything with content types please. That is something and nothing to do with permissions in this case.
0
 

Author Comment

by:COHFL
ID: 41735052
I was able to add a new user to the list but once again I cant delete.
0
 
LVL 19

Expert Comment

by:Walter Curtis
ID: 41735059
There could be item level permissions in use. As Tim mentioned one place to set that is in the advance settings for the list, although your ownership should override those settings. The other place is the item itself. The item(s) may have unique permissions that keep anyone from deleting them.

Go to the item and you should see a context menu for permissions.
0
 

Author Comment

by:COHFL
ID: 41735065
We may be heading somewhere this is what I see when I try to access the Items permissions
Capture.JPG
0
 
LVL 19

Expert Comment

by:Walter Curtis
ID: 41735074
Make sure you are logged in with the same account you checked the permissions for. Sounds weird, but if you are using pass through authentication, maybe your standard users account logged in automatically and you need to sign in to SharePoint using  your admin account.
0
 
LVL 10

Accepted Solution

by:
Tim Edwards earned 500 total points
ID: 41735087
Okay I think that I have found were the issue might might be...

Click on List and the Modify View:
SharePoint.PNG
Scroll down until you see Tabular View and make sure that All individual item checkboxes is selected
SharePointBrokenPermissions.PNG
I unchecked it in one of my lists and I lost the control and acts exactly like yours.
SharePointListPermissions.PNG
0
 
LVL 19

Expert Comment

by:Walter Curtis
ID: 41735094
You should still be able to mark an item directly (without the checkbox), which will activate the ribbon items. But give it a try, it might work! My fingers are crossed.

Good find!
0
 

Author Closing Comment

by:COHFL
ID: 41735101
Im not sure how to grade this one but Tim discovered was right on.
0
 
LVL 19

Expert Comment

by:Walter Curtis
ID: 41735115
Good you got it fixed. Glad to see Tim making some solid SharePoint solutions. Good Job
0
 
LVL 10

Expert Comment

by:Tim Edwards
ID: 41735317
Thank you,

I am only guessing that the previous admin, removed tabular and also hid the linked item so when click on any list item you would not get the prompt window.

I am just glad we were able to figure it out, it is not something that I have done before so it took a lot of brain searching to remember were some of these things are.

Have a great day and weekend
0

Featured Post

[Webinar] Learn How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When installing SharePoint 2010 RTM I came across a strange error, I was getting timeouts during the installation. I searched the web and found the best solution to be found here (http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010genera…
When using a search centre, I'm going to show you how to configure Sharepoint's search to only return results from the current site collection. Very useful when using Office 365 with multiple site collections.
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question