Server 2008 Printing thru rdp not working.

Hello experts,
I have a client with a Server 2008 R2 Datacenter.   It is not a DC, workgroup only.
Have RDS server with 15 licenses - user cals.  
I know that it will not report or track user cals in a workgroup environment.
But what I do not know is if that will keep me from printing remotely but I don't think that is it.

When a user logs in, all their local printers show up fine as redirected with TS ports as they should.
I have gone into GP and changed the setting to disable "use easy print drive first".
RDP user machines are window 8, 8.1 or 10 -  x64.
When they print it spools and disappears.  The error is in  event viewer under print service.
This is the error:
The document Test Page, owned by USERNAME, failed to print on printer RJHP277 (HP Color LaserJet MFP M277dw) (redirected 24). Try to print the document again, or restart the print spooler.
Data type: RAW. Size of the spool file in bytes: 143175. Number of bytes printed: 0. Total number of pages in the document: 1. Number of pages printed: 0. Client computer: \\namehere. Win32 error code returned by the print processor: 5. Access is denied.
Found this:
https://www.experts-exchange.com/questions/24795160/Event-ID-6161-Win32-error-code-returned-by-the-print-processor-5-Access-is-denied-Source-Microsoft-Windows-PrintSpooler.html

So I changed permissions to allow access to c:\windows\system32\spool - .  but had following errors when trying to give all users full control.
"An error occurred while applying security information to:
c:\windows\system32\spool\prtprocs...\LXKPTPRC.dll.mui.  Access is denied"
Next is:
"An error occurred while applying security information to:
c:\windows\system32\spool\prtprocs\x64\winprint.dll.  Access is denied"
Next:
"An error occurred while applying security information to:
c:\windows\system32\spool\tools.  Access is denied"
I continued on though and did another test print.  Had the same error.
I am an administrator on the system.
I am able to create a file (.txt) in the spool folder and then delete it.  I did not try another folders below that.
I don't know whether to chase the issue with the permissions on the spool folder or something else.
Any help will be most appreciated.
LVL 1
4rgAsked:
Who is Participating?
 
joharderConnect With a Mentor Commented:
Not likely.  If you didn't have RDS CALs, users wouldn't even be able to connect.  

Are you still in the 120-day RDS grace period?  If so, that may be why the per-user RDS CALs are working in a workgroup environment.

In reviewing everything, I still think that this is related to printer drivers, not RDS licensing.  It sure sounds like the print job begins to spool and then a printer driver issue and/or related permissions issue causes it to fail.

What is the level of User Account Control set on this server?
0
 
Adam BrownSr Solutions ArchitectCommented:
Install the printers on the server itself and disable printer redirection. The redirect is probably failing due to the computers or local users on the computers having inadequate permission to print.
0
 
4rgAuthor Commented:
Hi Adam,
Thank you for your time.
I forgot to mention in my original post that I actually tried that and it did not work.  
As mentioned earlier, I am an administrator so permissions should not be an issue, right?
Since I posted the question, I have uninstalled the Print Services Role (it was the only piece installed of that role) and restarted the server, then reinstalled.  Still experiencing the same problem.
Any other thoughts?
J
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
yo_beeDirector of Information TechnologyCommented:
I know this has nothing to do with the topic, but Datacenter version of the OS for a Workgroup setup.
Seems a bit overkill and expensive if you are not deploying a large number of servers.
0
 
joharderCommented:
Can you go in and remove the policy to remove the use of the easy print driver?  If the printers are mapping correctly into the user session, your printing issue could be related to not having a printer driver available for the print job.  If that's successful, and you don't wish to use that driver, you'll need to enable the installation of printer drivers so that print jobs have drivers.

If that works, then you should also remove the permissions change you made to the c:\windows\system32\spool folder.  There should be no reason to modify permissions on this folder.
0
 
4rgAuthor Commented:
Everyone, thanks for looking at this.

To Yo-bee: I realize the Datacenter version is extreme overkill but the client installed this themselves.  Have bigger fish to fry at the moment though than to criticize their choices, you know?  Thank you for the input though.

To joharder:  I had changed the policy to remove the use of easy print drivers when I installed my own drivers.  That was part of that test for me.  Failed miserably.  I always get access denied error 372.  I have noticed today that there I am low on ram, Physical Memory Usage History is pegged at 14.2gb out of 15gb and there is a message in the Google cloud console that this server is over utilized.  Can lack of ram prevent printing?  I had never heard of that.
J
0
 
joharderCommented:
Did you reboot and/or reapply GPOs after making changes to the printer GPO?

Is your print spooler service failing as well?

If you do a printui /s, what does it show as the installed drivers on the server?  What about on the client devices?
0
 
4rgAuthor Commented:
I did reapply GPOs after making changes to the printer GPO.
I also rebooted.
My print spooler service is not failing though I restart it manually after every failure test.

My drivers are installed on both the server and the client.  
I ran the command as you asked though and it just opened the  Print Server properties and shows the same drivers as found in Server Manager - Print and Document Services - Print Management - Print Servers - Instance name - Drivers area.  
Not sure what you were looking for by running the command line, am I missing something here?

To be clear, here is the exact message I have after enabling the administrator account (my client had disabled it for security reasons/best practices) and logging in as the original administrator account and trying to print.
The document Test Page, owned by Administrator, failed to print on printer RJHP277 (HP Color LaserJet MFP M277dw) (redirected 28). Try to print the document again, or restart the print spooler.
Data type: RAW. Size of the spool file in bytes: 143189. Number of bytes printed: 0. Total number of pages in the document: 1. Number of pages printed: 0. Client computer: \\myservername. Win32 error code returned by the print processor: 5. Access is denied.
0
 
joharderCommented:
Rather than trying to give users full control of the C:\Windows\System32\Spool folder, just give them read and write access.  According to this MS article, that should fix it.
0
 
4rgAuthor Commented:
Something strange I want to mention, I noticed it before but spoke with a friend (network engineer) and they said it would not cause this issue.  The RD Licensing Manager does not show any Issued licenses.  Though it does show 10 and 5 RDS per user cals installed respectively.  There are 25 users logged in and working though.  I have read that you cannot use RDS per user cals in a workgroup environment, they must be per device cals.  Could this be causing my no printing issue do you think?
0
 
4rgAuthor Commented:
Oh, and I changed permissions and removed full control, still left write access, no help.
0
 
4rgAuthor Commented:
Hi Joharder,
We are not in the 120 day grace period.

The UAC for my account is never notify.  I did not change it.

I understand your thinking but after installing my driver locally and using easy print as default and not using easy print as default and it not working still, I don't know where to go with this.  
BTW, I can print to a pdf writer, they have cutepdf installed and it works.  Then I can send the pdf to myself and print it locally.  That has been their work around.  Does that information help you at all?   Since I don't understand the differences between the two it does not help me.

Thanks again, really appreciate it.
0
 
joharderCommented:
Can you post a screen shot of the print drivers installed on a local device and the print drivers installed on the server?
0
 
4rgAuthor Commented:
Sure, thanks.  
As mentioned earlier I did locally install (to the server) the default printer driver from my local computer.
local-drivers1.jpg
local-drivers2.jpg
Server-drivers.JPG
0
 
joharderCommented:
A few questions:
 - Can you verify that the PDF Factory5 NT x86 driver is not a kernel driver?
 - Are you properly licensed for PDF Factory5 on the server (i.e., is it the $60 license)?  If not, remove both PDF Factory5 drivers.
 - Is the MFP M277 driver on the server the PCL6 version?
 - On the client device, can you add one of the printer drivers that is already on the server, e.g., HP DeskJet F4400 and try printing.
0
 
4rgAuthor Commented:
I don't care about the PDF drivers as they work.
The MFP M277 driver is the PCL6 version, that is mine.  I installed it to the server as one of the first things I did.
It is installed on the client device, same driver.  It does not print.
0
 
joharderCommented:
You have two PDF drivers, CutePDF and PDF Factory.  CutePDF is freeware and widely used, whereas PDF Factory is not.  Of all the drivers on the list, PDF Factory would be suspect as it is the only Windows NT x86 driver.  In addition, if it's not licensed properly, it could be causing the issue.

Please try removing the PDF Factory drivers and rebooting.
0
 
4rgAuthor Commented:
Well, this problem was there prior to them purchasing the pdf factory license and yes purchased.
I am out of ideas.
0
 
4rgAuthor Commented:
I am closing this ticket and giving the points to joharder for helping me and sticking with me.  Though I don't want to mark anything as best solution as there has been no solution.  Maybe the things we tried will help someone else.
Thanks Joharder.
0
 
4rgAuthor Commented:
I think someone messed with the users and groups on this server and it is beyond repair.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.