Solved

linux service nerwork restart throwing eth1 not dound?

Posted on 2016-07-30
5
107 Views
Last Modified: 2016-08-03
[root@puppetmaster rules.d]# service network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:
Determining IP information for eth0... done.
                                                           [  OK  ]
Bringing up interface eth1:  Device eth1 does not seem to be present, delaying initialization.
                                                           [FAILED]
0
Comment
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
5 Comments
 
LVL 1

Author Comment

by:BharathKumarRaju DasaraRaju
ID: 41736120
[root@puppetmaster rules.d]# pwd
/etc/udev/rules.d
[root@puppetmaster rules.d]# ls -rtlh
total 12K
-rw-r--r--. 1 root root  54 Dec  8  2011 99-fuse.rules
-rw-r--r--. 1 root root 316 Nov 22  2013 60-raw.rules
-rw-r--r--. 1 root root   1 Jul 31 00:41 70-persistent-cd.rules
[root@puppetmaster rules.d]# cat *
# Enter raw device bindings here.
#
# An example would be:
#   ACTION=="add", KERNEL=="sda", RUN+="/bin/raw /dev/raw/raw1 %N"
# to bind /dev/raw/raw1 to /dev/sda, or
#   ACTION=="add", ENV{MAJOR}=="8", ENV{MINOR}=="1", RUN+="/bin/raw /dev/raw/raw2 %M %m"
# to bind /dev/raw/raw2 to the device with major 8, minor 1.

KERNEL=="fuse", MODE="0666",OWNER="root",GROUP="root"
[root@puppetmaster rules.d]#
0
 
LVL 1

Author Comment

by:BharathKumarRaju DasaraRaju
ID: 41736121
[root@puppetmaster dhclient]# pwd
/var/lib/dhclient
[root@puppetmaster dhclient]# cat dhclient-eth0.leases
lease {
  interface "eth0";
  fixed-address 10.0.1.124;
  option subnet-mask 255.255.255.0;
  option dhcp-lease-time 3600;
  option routers 10.0.1.1;
  option dhcp-message-type 5;
  option dhcp-server-identifier 10.0.1.1;
  option domain-name-servers 10.0.0.2;
  option interface-mtu 9001;
  option broadcast-address 10.0.1.255;
  option host-name "ip-10-0-1-124";
  option domain-name "ec2.internal";
  renew 0 2016/07/31 01:05:59;
  rebind 0 2016/07/31 01:29:58;
  expire 0 2016/07/31 01:37:28;
}
lease {
  interface "eth0";
  fixed-address 10.0.1.124;
  option subnet-mask 255.255.255.0;
  option routers 10.0.1.1;
  option dhcp-lease-time 3600;
  option dhcp-message-type 5;
  option domain-name-servers 10.0.0.2;
  option dhcp-server-identifier 10.0.1.1;
  option interface-mtu 9001;
  option broadcast-address 10.0.1.255;
  option host-name "ip-10-0-1-124";
  option domain-name "ec2.internal";
  renew 0 2016/07/31 01:04:29;
  rebind 0 2016/07/31 01:34:01;
  expire 0 2016/07/31 01:41:31;
}
[root@puppetmaster dhclient]# cat dhclient-eth1.leases
lease {
  interface "eth1";
  fixed-address 172.16.11.250;
  option subnet-mask 255.255.255.0;
  option routers 172.16.11.1;
  option dhcp-lease-time 3600;
  option dhcp-message-type 5;
  option domain-name-servers 172.16.0.2;
  option dhcp-server-identifier 172.16.11.1;
  option interface-mtu 9001;
  option broadcast-address 172.16.11.255;
  option host-name "ip-172-16-11-250";
  renew 2 2014/04/08 09:12:11;
  rebind 2 2014/04/08 09:37:06;
  expire 2 2014/04/08 09:44:36;
}
[root@puppetmaster dhclient]#
0
 
LVL 1

Author Comment

by:BharathKumarRaju DasaraRaju
ID: 41736122
[root@puppetmaster network-scripts]# pwd
/etc/sysconfig/network-scripts
[root@puppetmaster network-scripts]# ls -rtlh ifcfg-eth1
-rw-r--r--. 1 root root 104 Apr  8  2014 ifcfg-eth1
[root@puppetmaster network-scripts]# cat ifcfg-eth1
# Automatically generated by the vm import process
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=dhcp
TYPE=Ethernet

[root@puppetmaster network-scripts]#
0
 
LVL 79

Accepted Solution

by:
arnold earned 500 total points
ID: 41736138
Please post output from
List Interfaces
ifconfig -a
List HW components
lspci

The error means there is no eth1 interface.

If the network adapter are of different vendor, you have to make sure the attempt to bring up the network is after the modprobe

Does this error only occur after a kernel update?
0
 
LVL 1

Author Closing Comment

by:BharathKumarRaju DasaraRaju
ID: 41741090
thanks
0

Featured Post

CHALLENGE LAB: Troubleshooting Connectivity Issues

Goal: Fix the connectivity issue in the lab's AWS environment so that you can SSH into the provided EC2 instance.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

615 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question