Remote desktop certificate error

In attempting to connect to a remote site I install the certificate.
the response is "the certificate install was successful"
Then move on to the internal server and cannot connect due to a certificate error.
The same certificate has no install option, only an error that the computer cannot verify the certificate.
screen shots attached.

Is there a setting I need to change so it will recognize the cert?
As always thanks for your assistance.
Who is Participating?

Improve company productivity with a Business Account.Sign Up

HandofGodConnect With a Mentor Commented:
I would like to add you should use MMC certificate snap-in to accomplish this.
David Johnson, CD, MVPOwnerCommented:
This looks like a self-signed certificate these can never be trusted you have to accept/click ok for these
You have to install the certificate into the trusted root certificate authority for the local computer. It will work...
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

actsoftAuthor Commented:
Answering yes, did nothing.
I placed the certificate in the root using MMC.
still get the same error.
did I place the cert in the wrong place?
please see attached screen shots.
David Johnson, CD, MVPConnect With a Mentor OwnerCommented:
you have to add the root ca's certificate GEC-SBS-CA to the trusted root certificate providers
actsoftAuthor Commented:
In the end the customer sent a new certificate that when placed in the root worked.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.