Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Manually Fix KB3159398

Posted on 2016-07-31
7
Medium Priority
?
530 Views
1 Endorsement
Last Modified: 2016-08-01
I posted this a day or two ago and guess I didn't get enough detail. I thought the simple fix was to add Authenticated Users under Delegation and give them Read privileges but I don't think this is correct. Don't they need Read and Apply GPO?

Secondly I thought Authenticated Users (Read and Apply GPO) was just a standard, every GPO should have it under Delegation, but when I add Authenticated Users under Delegation it also adds Authenticated Users under Scope. I don't want that. I have a specific security group under Scope and when added that group is automatically put it under Delegation with Read and Apply GPO permissions.

So I am a little confused about what KB3159398 actually did. I don't really want to add caret Blanche add Authenticated Users under Delegation where ever it is missing do I?
1
Comment
Question by:LockDown32
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 8

Expert Comment

by:Senior IT System Engineer
ID: 41736811
You can check it first using this PowerShell script:

#Load GPO module
Import-Module GroupPolicy
#Get all GPOs in current domain
$GPOs = Get-GPO -All
#Check we have GPOs
if ($GPOs) {
#Loop through GPOs
foreach ($GPO in $GPOs) {
#Nullify $AuthUser & $DomComp
$AuthUser = $null
$DomComp = $null
#See if we have an Auth Users perm
$AuthUser = Get-GPPermissions -Guid $GPO.Id -TargetName “Authenticated Users” -TargetType Group -ErrorAction SilentlyContinue
 #See if we have the ‘Domain Computers perm
$DomComp = Get-GPPermissions -Guid $GPO.Id -TargetName “Domain Computers” -TargetType Group -ErrorAction SilentlyContinue
 #Alert if we don’t have an ‘Authenticated Users’ permission
if (-not $AuthUser) {
#Now check for ‘Domain Computers’ permission
if (-not $DomComp) {
                Write-Host “WARNING: $($GPO.DisplayName) ($($GPO.Id)) does not have an ‘Authenticated Users’ permission or ‘Domain Computers’ permission – please investigate” -ForegroundColor Red
}   #end of if (-not $DomComp)
else {
#COMMENT OUT THE BELOW LINE TO REDUCE OUTPUT!
               Write-Host “INFORMATION: $($GPO.DisplayName) ($($GPO.Id)) does not have an ‘Authenticated Users’ permission but does have a ‘Domain Computers’ permission” -ForegroundColor Yellow
}   #end of else (-not $DomComp)
}   #end of if (-not $AuthUser)
elseif (($AuthUser.Permission -ne “GpoApply”) -and ($AuthUser.Permission -ne “GpoRead”)) {
#COMMENT OUT THE BELOW LINE TO REDUCE OUTPUT!
Write-Host “INFORMATION: $($GPO.DisplayName) ($($GPO.Id)) has an ‘Authenticated Users’ permission that isn’t ‘GpoApply’ or ‘GpoRead'” -ForegroundColor Yellow
}   #end of elseif (($AuthUser.Permission -ne “GpoApply”) -or ($AuthUser.Permission -ne “GpoRead”))
else {
   #COMMENT OUT THE BELOW LINE TO REDUCE OUTPUT!
            Write-Output “INFORMATION: $($GPO.DisplayName) ($($GPO.Id)) has an ‘Authenticated Users’ permission”
        }   #end of else (-not $AuthUser)
    }   #end of foreach ($GPO in $GPOs)
}   #end of if ($GPOs)

Open in new window


From: https://blogs.technet.microsoft.com/poshchap/2016/06/16/ms16-072-known-issue-use-powershell-to-check-gpos/

And then manually add the permission one by one a necessary.
0
 
LVL 15

Author Comment

by:LockDown32
ID: 41736850
Thanks but it is the manual permissions I am questioning.....  please see the question.....
0
 
LVL 11

Expert Comment

by:TS4B
ID: 41736869
If you have a GPO targeted at a group named lets say "Finance-Users" you still need to add Authenticated Users under delegation with "Read" only selected (Deselect "Apply Group Policy" under Authenticated users)

If you need the policy to work for all authenticated users then you need to set both "Read" and "Apply Group Policy"

You do not need to add "Write" permissions etc to Authenticated users (Not recommended ever on authenticated users)

Capture.PNG
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
LVL 15

Author Comment

by:LockDown32
ID: 41736875
That is where the questions come in on manually fixing it. You are saying at the very least, under the delegation tab, that every GPO should have Authenticated Users, Read, checked and if it is targeting the Group Authenticated Users Apply Group Policy should be checked too?
0
 
LVL 11

Accepted Solution

by:
TS4B earned 2000 total points
ID: 41736883
Yes correct. So just to keep it simple.

If targeting specific groups, you need authenticated users added under delegation, but only the "Read" option should be allowed. Remove allow on all other area's

If the target is Authenticated Users, then this box & the Apply Group Policy should both be allowed.

If the Apply Group Policy is not allowed, then "Authenticated Users" would not show under the target scope on the GPO post creating it, and the policy will not work for anyone.

To test run gpresult /r /scope:computer on a workstation where a item targeted policy is not applying & check that it shows with an error such as "Error unknown" or "GPO Denied"
Then on Group Policy add Authenticated Users with Read only to that GPO, go back to workstation, reboot and run gpresult /r /scope:computer again. (You can leave the /scope:computer out if the policy is user based.)
0
 
LVL 15

Author Comment

by:LockDown32
ID: 41737263
OK. I corrected the Delegation but still no luck. GPRESULT /H on this workstations shows none of the GPOs linked to the Computers OU as being either Applied or Denied. Screen shot and GPRESULT attached,
Capture.PNG
gpresult.html
0
 
LVL 11

Expert Comment

by:TS4B
ID: 41738000
Just on a side note. Computer GPO's do not show on GPRESULT /R It shows User Settings only.
You need to run GPRESULT /R /SCOPE:COMPUTER from an elevated CMD Prompt, if running it from client side in order to view the Computer Settings. But that's different from the GPO Results wizard attached here.

It looks from screenshot that Computer objects focused GPO's are set under SBSComputers correct.

Can you confirm that the computer which you ran the wizard against is in this OU.
In addition can you confirm if this problem applies to all systems tested, or only this one single computer please.
And finally did you check this after waiting for replication to finish. It can take some time unless you manually kicked of replication.
0

Featured Post

New benefit for Premium Members - Upgrade now!

Ready to get started with anonymous questions today? It's easy! Learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently, Microsoft released a best-practice guide for securing Active Directory. It's a whopping 300+ pages long. Those of us tasked with securing our company’s databases and systems would, ideally, have time to devote to learning the ins and outs…
Uncontrolled local administrators groups within any organization pose a huge security risk. Because these groups are locally managed it becomes difficult to audit and maintain them.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
Suggested Courses

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question