• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 183
  • Last Modified:

Mac Permissions USB drive

Hello experts,

I have a fat32 usb drive that says I only have read only permissions to it.  It has all my music on it which was backed up from my pc.  Is there any way, either from terminal or any other way I can adjust the permissions without wiping it?

Thank you, Karen
0
klsphotos
Asked:
klsphotos
  • 3
  • 2
  • 2
  • +3
1 Solution
 
awed1Commented:
If the music was backed-up from your PC, can't you just plug it back into the PC and change your permissions there?

If you place it back into the PC, you might try this:

Place the usb drive back into the PC
Look at the computer in My Computer or This PC and see what the name of the USB drive is.
For instance it may be F: or G: etc.
For now, pretend that it is G:, but in the directions below substitute whatever its designation is.

Open a command prompt.
To do this, you can type cmd into a search bar.
You would then see a little command icon and cmd.exe would be written next to it.
Right click on the icon and choose Run as Administrator
Accept the request.
When the command prompt opens paste in these instructions:

icacls "G:" /grant Everyone:(OI)(CI)F

Safely remove the drive and try using it again.
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
@awed1 - icacls on a FAT32 file system?
0
 
rindiCommented:
If you only have read permissions on a fat partition, there is something wrong with the disk.

Use the disk's manufacturer's diagnostic utility to find out the disk's status.
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
awed1Commented:
sorry - my bad
0
 
Eoin OSullivanConsultantCommented:
You don't mention the manufacturer and capacity of your USB drive device which could be a factor
There are 2 things to check for
1. I know it might seem obvious but some USB devices (primarily USB memory sticks) have a physical read-only switch on them which you need to check for.
2. Most likely the issue is software based then plug the device into the Mac.  Select it in the Finder and use the Get Info option in the File menu or press (CMD + I).  Look at the bottom Sharing & Permissions section and tell us if it says Read only or read and write?  Also confirm the EXACT value in the Format in the General Information panel at the top of the screen.
0
 
klsphotosAuthor Commented:
ok. My mistake, it is NTFS file system and it shows that I have read only on the mac.  I plugged it into my pc here at work and can access all files without issue.  The permissions are already set to everyone full control but I realize this does not apply to mac.

I need access to these files on mac....

I am looking into copying them somewhere but is there an easier way to add permissions from the mac?  I'm guessing not
0
 
klsphotosAuthor Commented:
I resolved this:  I plugged the drive back into the pc and browsed the network from my mac and logged in with my windows credentials.  I am currently copying the files from my pc to my mac here at works local hard drive.  Once that is done and I have confirmed that I can access the files I will take the drive and format it on the mac using disk utility and copy the files back to the drive.

Once I am done all of this I will recreate my iTunes library and all my playlist and hopefully have my music back so I can go work out...geez.

Thanks for your help everyone!  I am going to award eoinsullivan since he did state some obvious things that I didn't know and I had no idea it was NTFS until I looked where he told me, thank you.
0
 
Eoin OSullivanConsultantCommented:
You can copy FROM the NTFS formatted drive in OSX with no issues .. you should not have any issues copying the music FROM the USB drive onto the Mac OSX system.  This is what you wanted to do so should be OK.

Now you cannot WRITE to the USB Drive from OSX by default.  That is NOT a permissions issue but related to the file-system NTFS which is not fully supported in OSX.

There are several ways around it ..
The best and most reliable is a 3rd party software called Paragon NTFS - http://www.paragon-software.com/home/ntfs-mac/index.html
Install and you can read/write same as on Windows PC
1
 
Eoin OSullivanConsultantCommented:
If you're comfortable in OSX Terminal you can also modify the core OSX system to allow the NTFS write feature in the native OSX drivers for NTFS (they are disabled by default) - for FREE
http://macdrug.com/free-ntfs-read-and-write-solutions-in-mac-os-x-el-capitan-or-older/
1
 
rindiCommented:
What OSX version are you using on the MAC?

First with finder check what label your disk has within "Volumes". Then open the terminal and then enter the following command:

diskutil info /Volumes/DRIVENAME | grep UUID

(replace "Drivename" with the label you found above).

Then you can add write support for that device in the fstab file using the following command:

sudo echo "UUID=ENTER_UUID_HERE none ntfs rw,auto,nobrowse" >> /etc/fstab

(replace "ENTER_UUID_HERE" with the UUID you got with your previous command).

After that remount the external disk and you should be able to write to it.
0
 
serialbandCommented:
Newer OS X just disables write access in the default automount as Rindi has pointed out.  It does support writing to NTFS, but Apple does not support you doing that.  I write to my NTFS drives frequently from my Mac.
1

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 3
  • 2
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now