I'd like to set a group policy forcing a weekly system restore point creation.

Windows 10 Pro workstations on a Windows Server 2008 R2 domain.  I'd like to set a weekly restore point creation on say Friday or Monday but the steps i've followed have lead to dead ends.  I was following this link:  https://social.technet.microsoft.com/Forums/windowsserver/en-US/85a9363c-7617-46fe-aebe-7ee5b6d2feca/configure-system-restore-schedule-via-group-policy?forum=winserverGP --

My problem:  When I get to Scheduled Tasks -> select "New" -> Scheduled Task -> It asks for the following:  Action, Name, Run, Arguments, Start In, Comments, Run As:,|  I created a name "System Restore Points" but it REQUIRES that I choose a program in the "Run" box.  Servers do not inherently have System Restore to my knowledge though it's browsing the local machine.  How do I have it call something from the workstation instead of the server?  I can't look at any of the other tabs until I choose something here.
LVL 1
Daniel ChecksumAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Daniel ChecksumConnect With a Mentor Author Commented:
Found a solution.

Going to run this script:  
''''Script to create manual system restore point without user intervention''''
If WScript.Arguments.Count = 0 Then
Set objShell = CreateObject("Shell.Application")
objShell.ShellExecute "wscript.exe", Chr(34) & WScript.ScriptFullName & Chr(34) & " Run", , "runas", 1
Else
GetObject("winmgmts:\\.\root\default:Systemrestore").CreateRestorePoint "ManualRestorePoint", 0, 100
End If
0
 
Gary DewrellConnect With a Mentor Senior Network AdministratorCommented:
To configure System Restore to run once a week via Group Policy, please refer to the following steps:
Create a new Task under [Computer Configuration\Preferences\Control Panel Settings\Scheduled Tasks],
type a name and choose SYSTEM account to run this task,
Switch to Triggers tab, click New, choose Weekly, click OK.
Switch to Action tab, click New, type " %windir%\system32\rundll32.exe"
in Program/script box, type " /d srrstr.dll,ExecuteScheduledSPPCreation"
in Add arguments box. Click OK.
Run "gpupdate /force" on client and check the task.
0
 
Daniel ChecksumConnect With a Mentor Author Commented:
Those were the steps I was attempting to follow from the link I posted.  I've attached a screenshot at the point i'm stuck at.  What do I put under "Run:"?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Daniel ChecksumConnect With a Mentor Author Commented:
0
 
Gary DewrellConnect With a Mentor Senior Network AdministratorCommented:
Sorry your screen shot does not appear to work.
I am using Server 2012r2 so my setup is a little different but hopefully this will point you in the right direction.

On mine I have the Run as: %windir%\system32\rundll32.exe
and the arguments as:  /d srrstr.dll,ExecuteScheduledSPPCreation
0
 
Daniel ChecksumConnect With a Mentor Author Commented:
OK, few things:  Number 1:  I was entering a scheduled tasks for Pre-Vista which is why I didn't get the "trigger" or "action" tabs.  Once I entered Later than Vista scheduled task I got the tabs the instructions mentioned.  I've implemented the GPO and ran gpupdate /force on my own machine but I don't see it in my "scheduled tasks"  --  should I be looking elsewhere?  The GPO is set to apply to "Domain Users" as we want this on every single machine in the office on the Domain.  I've set it for Monday at 7:30am so I won't REALLY know if it's working until Monday.  What's the next steps?
0
 
Daniel ChecksumConnect With a Mentor Author Commented:
I am now having the issue where I open "Group Policy Management" ->  Hit "Edit" on a policy to pull up the "Group Policy Management Editor" -> Create my group policy -> Go back to tree I want to "link existing GPO" to and my group policies don't appear in the list and upon going back to the editor, they have disappeared.  Why does this keep happening?
0
 
Gary DewrellConnect With a Mentor Senior Network AdministratorCommented:
Off the top of my head I have no clue. That does not make much sense. Are you editing an existing GPO or created a new one?
0
 
Daniel ChecksumConnect With a Mentor Author Commented:
Creating a new one.
0
 
Daniel ChecksumConnect With a Mentor Author Commented:
I've tried gpresults and rsop but I can't see where the scheduled task is being displayed on my workstation.  I did fix the 1:30am to PM and changed the "when this network connection is available.." to "Any" (Side question:  Does 'any' include no connection?)  

I just need to know if the GPO is ACTUALLY being applied to my station or not, and if it is running, since it's a scheduled task it's time consuming to have to wait for my scheduled time though I supposed I could run a separate test GPO on just my station.
GPO-Settings.png
tree-for-group-policy.png
0
 
Gary DewrellConnect With a Mentor Senior Network AdministratorCommented:
On a workstation, from an elevated prompt, run:

gprusult /H GPOApplied.html

Then open GPOApplied.html in your browser. You may have to click the expand all link in the top right corner.

The use CTRL-F to do a find and search for System Restore Point.

Yes to your side question.
0
 
Daniel ChecksumConnect With a Mentor Author Commented:
No workstation is getting this group policy.  I can't find it in gpresults and I even created another group and policy JUST to test with, put myself in the group and have gotten nothing.  gpupdate /force says it needs a reboot to complete the task, but doesn't pull any more group policies after a reboot.  I am completely stuck at this point, doesn't make any sense.
0
 
Gary DewrellConnect With a Mentor Senior Network AdministratorCommented:
Look in the system event log on your pc for any warning, errors, critical events.
0
 
Daniel ChecksumConnect With a Mentor Author Commented:
The only error even remotely pertaining to the group policy is this one:

Security policies were propagated with warning. 0x534 : No mapping between account names and security IDs was done.

Advanced help for this problem is available on http://support.microsoft.com. Query for "troubleshooting 1202 events".

Error 0x534 occurs when a user account in one or more Group Policy objects (GPOs) could not be resolved to a SID.  This error is possibly caused by a mistyped or deleted user account referenced in either the User Rights or Restricted Groups branch of a GPO.  To resolve this event, contact an administrator in the domain to perform the following actions:

1.      Identify accounts that could not be resolved to a SID:

From the command prompt, type: FIND /I "Cannot find"  %SYSTEMROOT%\Security\Logs\winlogon.log

The string following "Cannot find" in the FIND output identifies the problem account names.

Example: Cannot find JohnDough.

In this case, the SID for username "JohnDough" could not be determined. This most likely occurs because the account was deleted, renamed, or is spelled differently (e.g. "JohnDoe").

2.      Use RSoP to identify the specific User Rights, Restricted Groups, and Source GPOs that contain the problem accounts:

a.      Start -> Run -> RSoP.msc
b.      Review the results for Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment and Computer Configuration\Windows Settings\Security Settings\Local Policies\Restricted Groups for any errors flagged with a red X.
c.      For any User Right or Restricted Group marked with a red X, the corresponding GPO that contains the problem policy setting is listed under the column entitled "Source GPO". Note the specific User Rights, Restricted Groups and containing Source GPOs that are generating errors.

3.      Remove unresolved accounts from Group Policy

a.      Start -> Run -> MMC.EXE
b.      From the File menu select "Add/Remove Snap-in..."
c.      From the "Add/Remove Snap-in" dialog box select "Add..."
d.      In the "Add Standalone Snap-in" dialog box select "Group Policy" and click "Add"
e.      In the "Select Group Policy Object" dialog box click the "Browse" button.
f.      On the "Browse for a Group Policy Object" dialog box choose the "All" tab
g.      For each source GPO identified in step 2, correct the specific User Rights or Restricted Groups that were flagged with a red X in step 2. These User Rights or Restricted Groups can be corrected by removing or correcting any references to the problem accounts that were identified in step 1
.
0
 
Gary DewrellConnect With a Mentor Senior Network AdministratorCommented:
I would start a new question with a Subject like GPO Policies not applying to see if we can get some experts in AD/GPO issues involved.
0
 
Daniel ChecksumConnect With a Mentor Author Commented:
Should my GPO be Create or Update?
0
 
Daniel ChecksumAuthor Commented:
Going to use this VBS script as opposed to the arguments in my initial post.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.