Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Putty serial connect in windows 10 won't work

Posted on 2016-08-03
7
Medium Priority
?
5,963 Views
Last Modified: 2016-08-03
Hi All,

I used putty with no problems on windows xp.  Now I'm on windows 10 and when I use the serial connection with putty, I just get a blank black screen.  No login request.  Is their something I need to turn on in win 10 to get this to work?  Or, is there something else I could use other then putty.

Thank you in advance.
0
Comment
Question by:Reyesrj
7 Comments
 
LVL 99

Assisted Solution

by:John Hurst
John Hurst earned 500 total points
ID: 41741660
Do you have the latest version? It works fine on my Windows 10 machine.

Putty-Main-Window
0
 

Author Comment

by:Reyesrj
ID: 41741692
Thanks John,
Attached is what mine looks like.  I'm trying to use the serial connection.
putty1.JPG
Putty2.JPG
0
 
LVL 8

Accepted Solution

by:
Leo earned 1000 total points
ID: 41741704
under serial connection, try these settings;
9600 baud 8 data bits, 1 stop bit, and no parity Set flow control to none Under Properties, select VT100 for Emulation mode.
1
Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

 
LVL 51

Assisted Solution

by:Jackie Man
Jackie Man earned 500 total points
ID: 41741716
Is it a Cisco USB connection?
0
 
LVL 31

Expert Comment

by:Predrag
ID: 41741721
Is their something I need to turn on in win 10 to get this to work?
Typically no need to turn on anything (if drivers are installed for COM port.

In device manager check what are currently available COM ports, maybe you are using the wrong one.
1
 

Author Closing Comment

by:Reyesrj
ID: 41741738
Hi All,
It works now.

I'm using a cheap Prolific USB to Serial cable.

The last change I made was the Flow control in the windows com port.  It was set to "none".  Putty has it set to "Xon / Xoff".  I changed windows flow control to "Xon /Xoff" so they would be the same and it works now.

Thank you all!

Leo, it was your suggestion that got me to look at the settings.  I thought windows and putty would have the same default settings.
0
 
LVL 8

Expert Comment

by:Leo
ID: 41741788
Good to know it all worked out for you :-)
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article summaries thoughts and ideas from two years of sustained use. It provides good reasoning to make the jump to Windows 10.
This article is about my experience upgrading my consulting machine to Windows 10 Version 1709 (The Fall 2017 Creator Update)
Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
Suggested Courses

963 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question