?
Solved

Server 2012 R2 RDP sessions suddenly asking for smart card

Posted on 2016-08-04
11
Medium Priority
?
205 Views
Last Modified: 2016-08-07
Hi Experts,

since two days I have this issue on some servers.
These Servers are all WIN2012R2 and virtulized.

When I want to log in with my domain user account, it also asked for a smart card.

Do you have any ideas to prevent this ?
0
Comment
Question by:Eprs_Admin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
11 Comments
 
LVL 36

Expert Comment

by:Kimputer
ID: 41741911
On your remote desktop connection settings, do "Show More options", then tab Local Resources, More, uncheck Smart cards option. Save this profile, and you'll never face the smart card prompt again.

Another way is to go the RDS server properties, Session Collections, and for the Client Settings, uncheck the Smart cards option.
0
 

Author Comment

by:Eprs_Admin
ID: 41741953
Ok this works for RDP directly.
But I use a third party tool for remote desktop sessions -> mRemoteNG

Where to set this option for ever ?
0
 
LVL 36

Expert Comment

by:Kimputer
ID: 41742180
If you don't want the software to set it, set it at the server side (RDS server properties, Session Collections, and for the Client Settings, uncheck the Smart cards option.)
Obviously, if the software doesn't listen to the restrictions set, I can't really help you, only the makers of mRemoteNG can.
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 

Author Comment

by:Eprs_Admin
ID: 41742181
Can you show me where at the server side I can set it ?
0
 
LVL 36

Expert Comment

by:Kimputer
ID: 41742188
RDS server properties, Session Collections, Client Settings, Edit properties, uncheck the Smart cards option.
0
 

Author Comment

by:Eprs_Admin
ID: 41743771
ok,
but where are these settings on my server ?
Where to change it ?
Can you guide me please ?
0
 
LVL 36

Expert Comment

by:Kimputer
ID: 41743773
On the server, start Server Manager > RDS server properties, Session Collections, Client Settings, Edit properties, uncheck the Smart cards option.
0
 

Author Comment

by:Eprs_Admin
ID: 41744043
I use WIN2012R2.
Sorry, when I connect to my Server Manager there is no option to click RDS server Properties !!
On LOCAL SERVER I just have Remote Management and Remote Desktop and here are no settings for a smart card.

Where are the settings exactly, maybe you give me a screenshot.
0
 
LVL 36

Expert Comment

by:Kimputer
ID: 41744067
If the Server Manager doesn't display the RDS Server properties (probably because it's another server), then ADD the server first. Upper right corner Manage > Add servers.
0
 

Author Comment

by:Eprs_Admin
ID: 41744073
I am logged on to my server and on this server I want to change the settings.
Not on another server.

This is just a print server and when I login via RDP I get the message ...use a smart card....
With the administrator I can login but now with personal admin account.

Where do I change the settings.
Can you make ascreenshot ?
0
 
LVL 36

Accepted Solution

by:
Kimputer earned 2000 total points
ID: 41744101
If you don't have RDS server options, you are only logging in as admin. The whole point has now changed.
I was talking about a real RDS server to change the option for all users.
You are probably talking about the 2 admin RDP connections every server has available. There are no options to set there. You are now depending on the client to disable it (where I already showed you the MS RDP client, but you didn't know how to set it for the 3rd party one).
So, check with the 3rd party if you can save a profile without the smart card option. It's the only way forward.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Active Directory security has been a hot topic of late, and for good reason. With 90% of the world’s organization using this system to manage access to all parts of their IT infrastructure, knowing how to protect against threats and keep vulnerabil…
Compliance and data security require steps be taken to prevent unauthorized users from copying data.  Here's one method to prevent data theft via USB drives (and writable optical media).
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question