• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 119
  • Last Modified:

lost printers in remote desktop

Hi, just recently all the users in one of our remote offices lost all their locally attached printers in remote desktop session.  I stopped and started the print spooler service on the server but no luck.  I went into the c:\windows\system32\spools  folder and saw that in the printers
folder there were lot temp files referencing shockwave files and i seem to remember way back that these files come from printing pdf files that dont print properly and can cause issues.  Any ideas?
0
dankyle67
Asked:
dankyle67
  • 5
  • 3
1 Solution
 
Edward PamiasTeam Lead RRS DeskCommented:
Did you try resetting the spooler on the local workstation?
0
 
dankyle67Author Commented:
I will try resetting the spooler on the client pc and see if it helps.  The printers always show up in the past few months no problem but just happened this morning where they all disappeared.
0
 
Edward PamiasTeam Lead RRS DeskCommented:
Let me know how that works. I had a similar problem and the printers reappeared after I reset the spooler on the workstation.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
Edward PamiasTeam Lead RRS DeskCommented:
Also, In the Remote Desktop "Connection Box" click on Options/ Local Resources, make sure that Printers is ticked.
1
 
dankyle67Author Commented:
Just did it on workstation and worked like a charm.  I would always do it from the server and it would work but this time is first time it worked using spooler from workstation.  Thanks for the quick resolution.
0
 
Edward PamiasTeam Lead RRS DeskCommented:
Server 2008 Config...


    Go to “Start” > “Administrative Tools” > “Remote Desktop Services” > “Remote Desktop Session Host Configuration“.
    Select “Connections“, right-click the name of the connection > “Properties” > “Client Settings” > “Redirection“. Ensure that “Windows Printer” is not checked.


Server 2012 Config...


    Open “Server Manager“.
    Select “Remote Desktop” Services.
    Select “Collections“.
    Select “Tasks“, then choose “Edit Properties“.
    Under the “Client Settings” tab, ensure the “Windows Printer” is enabled.
0
 
Edward PamiasTeam Lead RRS DeskCommented:
I am glad it worked. I added some other things for the future just in case you need it. :)
0
 
dankyle67Author Commented:
Good stuff will definitely check it out and thanks again
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now