Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

BootCamp Partition - Lost Windows Partition MBR

Posted on 2016-08-06
4
Medium Priority
?
90 Views
Last Modified: 2016-09-21
I have been using BootCamp on my mac for years, with no issues.  About 6mo ago, I noticed I needed more space on my Windows Side, so I resized my partitions... everything seemed to go fine... I am running windows 10 on the Windows side & El Capitan on the Mac Side...

I really do not use the Mac side barely at all, but I want to be able to have both, the best of both worlds...

So basically I went to go onto my Mac side yesterday & rebooted into the Mac side, no problems!  Did what I needed to on that side & then went to Restart in Windows Partition & there is NO windows Partition anymore in the Startup Disk ... It just has the Mac OS X ... I am guessing I never saw any issue before this because I never went to the mac side...

I really don't want to have to do a FRESH install of both again... if I can help it...

IS THERE ANY SOLUTION  or an EASY FIX ( I know I am reaching... hoping & praying ) to get the MBR back in some way?  that is what it looks like as I was searching around...

I tried to do what this article said, but nothing changed...  http://nerdr.com/bootcamp-partition-lost-repairing-mac-partitions/

When I restart & hold down the OPTION key, 3 choices come up, Mac OS X / Recovery / Windows, when I choose Windows it says, MISSING OPERATING SYSTEM...

I want to be able to at least get the data off the drive & really don't want to pull my iMac apart to get to the hard drive & then if the data is even there??

Will the data be there??  in Disk Utility I can see there 500gb of Untitled, but I know that was my Windows Partition, before I ever tried to resize... the resized partition should be 750gb I think...

Anyway, I hope someone can help...

This something else I ran, hopefully it will be helpful to someone that can read it & know what it is saying...

From Terminal:
Last login: Sat Aug  6 18:20:15 on console
Etronics6-iMac:~ etronics6$ sudo gpt -r -vv show disk0
Password:
gpt show: disk0: mediasize=1000204886016; sectorsize=512; blocks=1953525168
gpt show: disk0: Suspicious MBR at sector 0
gpt show: disk0: Pri GPT at sector 1
gpt show: disk0: Sec GPT at sector 1953525167
       start        size  index  contents
           0           1         MBR
           1           1         Pri GPT header
           2          32         Pri GPT table
          34           6        
          40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
      409640   591229312      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
   591638952     1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
   592908488   384055096        
   976963584   976560128      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
  1953523712        1423        
  1953525135          32         Sec GPT table
  1953525167           1         Sec GPT header
Etronics6-iMac:~ etronics6$ sudo fdisk /dev/disk0
Disk: /dev/disk0      geometry: 121601/255/63 [1953525168 sectors]
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
------------------------------------------------------------------------
 1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>
 2: AF 1023 254  63 - 1023 254  63 [    409640 -  591229312] HFS+        
 3: AB 1023 254  63 - 1023 254  63 [ 591638952 -    1269536] Darwin Boot
*4: 07 1023 254  63 - 1023 254  63 [ 976963584 -  976560128] HPFS/QNX/AUX
Etronics6-iMac:~ etronics6$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            302.7 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
   4:       Microsoft Basic Data                         500.0 GB   disk0s4
Etronics6-iMac:~ etronics6$

One other thing i did today was upgrade to El Capitan, thinking that would help matters... the disk utility looks different now, BEFORE El Capitan I could see the Disk0s4, now I get a graphic like this one I have embedded ... I can see the Windows partition, but now it doesn't have the Disk0s4 anymore on the left... now it is ALL TOGETHER...

 Disk Utility Partitions
I hope someone can help... thank u in advance for any assistance you can offer to get me to a solution!!
0
Comment
Question by:etronics6
4 Comments
 
LVL 10

Accepted Solution

by:
davidanders earned 1000 total points
ID: 41746281
You do not mention what OSX version before the El Capitan upgrade.
You do not mention what was used to resize the Windows partition.
Do you have a backup of the Windows partition (done in Windows)?
Do you have a backup of the BootCamp partition (done in OSX)?
WinClone is often recommended  http://twocanoes.com/products/mac/winclone
Do you have a backup of the OSX partition?
TimeMachine, SuperDuper, and Carbon Copy Cloner are most often the recommended utilities.

Apple neutered Disk Utility in El Capitan and users were displeased. Sierra's version is slightly more ballsy.
https://www.google.com/search?q=el+capitan+disk+utility

Bootcamp won't start after resizing partition
http://apple.stackexchange.com/questions/180352/bootcamp-wont-start-after-resizing-partition
0
 
LVL 31

Assisted Solution

by:serialband
serialband earned 1000 total points
ID: 41748252
What did you use to resize the Windows partition?  iPartition and CamptuneX are two other useful tools that work to resize NTFS and HFS+ partitions.

OS X can not operate on NTFS partitions on its own.  You need 3rd party software to manage them.  If you resized it using Disk Utility, you've messed it up.  You should always have backups when you mess around with disk partitions, no matter which tool you use.
0
 

Author Comment

by:etronics6
ID: 41750832
Sorry guys!!  I've been dealing with health issues for my sister & haven't been able to get back to u or work on this computer...

I used partitionwizard.com...
I had Yosemite
I have win 10 on win side

Not sure when I can try to do this with everything going on, hard to wrap my head around this right now, sorry...

My main thing is, I am probably going to pull the drive, I just didn't want to do that, it's an iMac & u have to pull the screen off to get to drive... Etc...

I was hoping there might be an easy way (which I know there usually never is). Just didn't want to have to rebuild everything with what's going on with my sis... So I thought I would throw it out there...

Thanks for ur help thus far!! I appreciate it!
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Windows 10 Creator Update has just been released and I have it working very well on my laptop. Read below for issues, fixes and ideas.
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

972 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question