• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1262
  • Last Modified:

Unable to install ESXi latest patch from Putty console ?

Hi All,

I'm using Vmware ESXi 5.5U3 and I need some help here to perform the patch / update of my ESXi with the latest patch that I've uploaded already to local VMFS data store.

VMkernel PRODESXi01.KTM.COM 5.5.0 #1 SMP Release build-3568722 Feb 18 2016 16:42:56 x86_64 GNU/Linux

/vmfs/volumes/5343eda3-9ea90c05-129d-80c16e66af30 # esxcli software vib install -d ESXi550-201608001.zip
 [MetadataDownloadError]
 Could not download from depot at zip:/var/log/vmware/ESXi550-201608001.zip?index.xml, skipping (('zip:/var/log/vmware/ESXi550-201608001.zip?index.xml', '', "Error extracting index.xml from /var/log/vmware/ESXi550-201608001.zip: [Errno 2] No such file or directory: '/var/log/vmware/ESXi550-201608001.zip'"))
        url = zip:/var/log/vmware/ESXi550-201608001.zip?index.xml
 Please refer to the log file for more details.

/vmfs/volumes/5343eda3-9ea90c05-129d-80c16e66af30 # esxcli software vib update -d ESXi550-201608001.zip
 [MetadataDownloadError]
 Could not download from depot at zip:/var/log/vmware/ESXi550-201608001.zip?index.xml, skipping (('zip:/var/log/vmware/ESXi550-201608001.zip?index.xml', '', "Error extracting index.xml from /var/log/vmware/ESXi550-201608001.zip: [Errno 2] No such file or directory: '/var/log/vmware/ESXi550-201608001.zip'"))
        url = zip:/var/log/vmware/ESXi550-201608001.zip?index.xml
 Please refer to the log file for more details.
/vmfs/volumes/5343eda3-9ea90c05-129d-80c16e66af30 #

Can anyone here please help me ?

My VCenter appliance is already updated to version  5.5.0.30500 Build 4180648.
0
Senior IT System Engineer
Asked:
Senior IT System Engineer
  • 2
  • 2
2 Solutions
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
try this

make sure host is in maintenance mode

esxcli network firewall ruleset set -e true -r httpClient
esxcli software profile update -p ESXi-5.5.0-20160804001-standard -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml
esxcli network firewall ruleset set -e false -r httpClient

Open in new window

1
 
Richardson PortoSenior Infrastructure SpecialistCommented:
Try use the FULL path for your bundle, something like esxcli software vib install -d /vmfs/volume/5343eda3-9ea90c05-129d-80c16e66af30/ESXi550-201608001.zip assuming 5343eda3-9ea90c05-129d-80c16e66af30 is your datastore UUID.
1
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Make sure you have updated vCenter Server first to 5.5 Update 3! otherwise the current version of vCenter Server will not manage ESXi 5.5 U3.
1
 
Richardson PortoSenior Infrastructure SpecialistCommented:
Based on build number
5.5.0.30500 Build 4180648.
vCenter are already on U3, to be exact, the version  5.5 Update 3e.
1
 
Senior IT System EngineerIT ProfessionalAuthor Commented:
Thanks all for the assistance yes it is working and I'm learning new stuff from you :-)
0

Featured Post

Cyber Threats to Small Businesses (Part 2)

The evolving cybersecurity landscape presents SMBs with a host of new threats to their clients, their data, and their bottom line. In part 2 of this blog series, learn three quick processes Webroot’s CISO, Gary Hayslip, recommends to help small businesses beat modern threats.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now