Solved

How to access an IP camera remotely

Posted on 2016-08-08
25
148 Views
Last Modified: 2016-08-27
Hi,

I've given up tweeking various IP security cameras to send images etc correctly, so i'm looking instead to monitor them externally.

First step is the make the cameras accessible outside the LAN, is there a dummies guide to do this? Some kind of port forwarding on the router.

I will do this on 3 different networks, so a generic explanation would be ideal.

Cheers
0
Comment
Question by:xenium
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 12
  • 8
  • 4
  • +1
25 Comments
 
LVL 16

Assisted Solution

by:FOX
FOX earned 125 total points
ID: 41747541
0
 
LVL 5

Assisted Solution

by:Manuel Flores
Manuel Flores earned 125 total points
ID: 41747543
Exactly you need a NAT config to expose the cameras outside...  a port mapping it is desirable too if the standar port are the standard ones;  (maybe 443 or 80) mapped to 4443 or 8088 or similar.

 http://wiki.mikrotik.com/wiki/NAT_Tutorial
0
 
LVL 23

Accepted Solution

by:
tailoreddigital earned 250 total points
ID: 41747545
You need to figure out what port or set the port on the camera, then forward that port on the router.   You use a different port number for each camera.  

You can use something like BlueIris to monitor cameras from all 3 locations.

If we know what types of equipment you're using, we can give you more specific answers.

What router are you using and what camera models are you using?
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 

Author Comment

by:xenium
ID: 41747699
THanks for all the info. I'm looking through it.

Here are specifics on one of the cameras:

Router: Netgear N150 model DGN1000

IP camera: Wanscam something like this http://www.wanscam.com/cd/index.php?ac=article&at=list&tid=136

Device Firmware Version	  67.2.2.180
   Device Embeded Web UI Version	  9.0.4.70
   Alias	  IPCAMERA3
   Device ID	  JWEV-234457-BACFE

Open in new window

0
 

Author Comment

by:xenium
ID: 41747703
Local camera IP is http://192.168.0.12:99/
0
 

Author Comment

by:xenium
ID: 41747710
Netgear options attached
netgear.JPG
0
 
LVL 5

Expert Comment

by:Manuel Flores
ID: 41747718
OK.  You need to setup a rule into the netgear box to redirect external traffic on port 99 to internal ip 192.168.0.12 port 99.
0
 
LVL 5

Expert Comment

by:Manuel Flores
ID: 41747726
Then using your public IP:   http://x.x.x.x:99 you will access the cameras from outside.
It is good idea to restrict access from the locations (IP's) from which you access normally.  This feature is a firewall rule that your netgear box maybe doesn't support.  Must check.
0
 
LVL 5

Expert Comment

by:Manuel Flores
ID: 41747732
From xenium screenshot, it seems that your netgear has firewall.
0
 

Author Comment

by:xenium
ID: 41747894
Ok great thanks. Which settings do i need to tweak on the router?

Setup
	Basic Settings
	ADSL Settings
	Wireless Settings
Security
	Logs
	Block Sites
	Firewall Rules
	Services
	Schedule
	E-mail
Maintenance
	Router Status
	Attached Devices
	Backup Settings
	Set Password
	Diagnostics
	Router Upgrade
Advanced
	WAN Setup
	Dynamic DNS
	LAN Setup
	Wireless Settings
	Remote Management
	Static Routes
	UPnP

Web Support
	Knowledge Base
	Documentation

Open in new window

0
 
LVL 5

Expert Comment

by:Manuel Flores
ID: 41747896
Probably Firewall rules and Services.
0
 

Author Comment

by:xenium
ID: 41747944
Services: what should the setting be here:

Service Definition
Name:	
Type:	TCP/UDP
Start Port:	
Finish Port:

Open in new window

0
 

Author Comment

by:xenium
ID: 41747946
Firewall settings:

 
Outbound Services
 	#	Enable	Service Name	Action	LAN Users	WAN Servers	Log
 	Default	Yes	Any	ALLOW always	Any	Any	Never

 Add    Edit    Move   Delete
Inbound Services
 	#	Enable	Service Name	Action	LAN Server IP address	WAN Users	Log
	1		SSH	ALLOW always	192.168.0.17	Any	Never
 	Default	Yes	DMZ	ALLOW always	192.168.0.3	Any	Never
 	Default	Yes	Any	BLOCK Always	Any	Any	Never

Open in new window

0
 

Author Comment

by:xenium
ID: 41750575
I have tried this, see attached Service and Firewall settings used. No luck.

I'm using the IP from IP chicken and then adding :99

Any ideas?

Thanks
add-service.JPG
inbound-service.JPG
0
 

Author Comment

by:xenium
ID: 41750577
PS I accidentally deleted an existing service (no warning on Netgear, and no option to view an existing service so I could screenshot it) not sure what it was, hopefully router will continue to work!
0
 
LVL 5

Expert Comment

by:Manuel Flores
ID: 41750617
I think the router should allow that traffic without having to create a rule explicitly, because you have configured an inbound service.  Anyway, you could try to add this;

Inbound Services
 	#	Enable	Service Name	Action	LAN Server IP address	WAN Users	Log
	2		WANSCAM	ALLOW always	192.168.0.12	Any	Never

Open in new window

0
 
LVL 5

Expert Comment

by:Manuel Flores
ID: 41750622
so from anyplace you should be able to open an internet explorer and go to;

http://(public ip of your router):99
0
 

Author Comment

by:xenium
ID: 41754993
Hi Manuel, isn't your suggestion what i've done in the previous post? Apart from logging.
0
 
LVL 5

Expert Comment

by:Manuel Flores
ID: 41754997
Did you try to setup this?;

Inbound Services
       #      Enable      Service Name      Action      LAN Server IP address      WAN Users      Log
      2            WANSCAM      ALLOW always      192.168.0.12      Any      Never

Anyway, I'm asserting; it should work.
0
 

Author Comment

by:xenium
ID: 41756818
hi Manuel, yes this is what i tried.

I attached 2 screenshots in that post:
https://filedb.experts-exchange.com/incoming/2016/08_w33/1110931/inbound-service.JPG
https://filedb.experts-exchange.com/incoming/2016/08_w33/1110930/add-service.JPG

The first is what you suggested (except the log)
The second, does it look correct?

Cheers
0
 
LVL 23

Expert Comment

by:tailoreddigital
ID: 41756835
Your settings look correct.    How are you viewing your camera?   A browser, an app?
0
 

Author Comment

by:xenium
ID: 41756836
Strange it is now working.

It might be a co-incidence, but I tried turning on Remote Management and then turning it off again.
0
 
LVL 23

Expert Comment

by:tailoreddigital
ID: 41756839
Sounds like a co-incidence.   Remote Management shouldn't make a difference.
0
 
LVL 23

Expert Comment

by:tailoreddigital
ID: 41756842
If it becomes inconsistent, you might have a failing router.   Once this is configured, it's shouldn't flake out.     When network configurations are correct, it should stay consistent.
0
 

Author Comment

by:xenium
ID: 41763687
Thanks all, sorry for delay. I will close this and assign points shortly.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question