Exchange 2016

I have an exchange 2016 server running on Windows 2012 Standard server. The problem that I am having is that the address book only updates for some of the user not all of them. In other words if I add a new user that user will only show up in the global address list of some of the users but not all of them. If those users go to all users in the address book they can fine the new user there but not in the Global address list.
These are the command that I have tried so far:
Update-GlobalAddressList -Identity "Default Global Address List"

Update-OfflineAddressBook "default offline address book"

None of these have worked. I need to get all the new users when added to show up in every users Global address list.
bmicAsked:
Who is Participating?
 
FOXActive Directory/Exchange EngineerCommented:
Have those outlook clients in question uncheck use cached exchange mode and then restart outlook. If they need to put it back in cached exchange mode after they see the new addresses that is totally up to you.
2
 
El FierroNetwork EngineerCommented:
have you ran this command:
Get-AddressList | update-AddressList
0
 
Todd NelsonSystems EngineerCommented:
OAB updates are made, on the Exchange server, automatically once every 24 hours--typically between 3am-5am local time.  The Outlook client will need to be closed (if left open) and then reopened for those changes to be realized in Outlook when cache mode is enabled.

Alternately, after perfoming the steps you outlined in your question, from the Outlook client you can select "Send/Receive" from the toolbar, click "Send/Receive Groups", and choose "Download Address Book". Then disable the option to "Download changes since last Send/Receive" and click OK. This action will download the full (and most current) address book for the individual Outlook user.

As a last resort, you can disable cache mode in Outlook so your users see the live address book from Exchange. However, that will create a lot of traffic on the server as now the Outlook users will be making constant requests to the Exchange server and experience latency when viewing items.

Hope this helps.
0
Get Cisco Certified in IT Security

There’s a high demand for IT security experts and network administrators who can safeguard the data that individuals, corporations, and governments rely on every day. Pursue your B.S. in Network Operations and Security and gain the credentials you need for this high-growth field.

 
bmicAuthor Commented:
thanks for the responses. Foxluv your answer solved my issue... Thanks
0
 
Todd NelsonSystems EngineerCommented:
Hopefully disabling Exchange cache mode and then reenabling it doesn't create a new OST file and/or a redownload of all of the messages from the Exchange mailbox to the local workstation.
0
 
bmicAuthor Commented:
Todd no it didn't and it's funny some of the machine that were having that problem i just unchecked it and left it unchecked and everything is good other machines were fine so i left it checked and all is good. not sure why that is...
0
 
bmicAuthor Commented:
This seem to work for me. Thanks.....
0
 
Todd NelsonSystems EngineerCommented:
BMIC,

Awesome! I hate OAB. It's so finicky.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.